Movie Database Does Not Start

I just installed neo4j desktop and tried to run movie database but it gives error. Version is 4.1.0
Windows 10. I could not understand what is wrong from logs.
Database failed to start: DB [database-5db1a868-35bf-44e0-a100-13442dfbbbe6] 'v4.1.0' exited with status 'KILLED'. Check the logs
This is the log:
2020-07-16 09:07:58.862+0000 INFO Starting...
2020-07-16 09:08:01.998+0000 ERROR Failed to start Neo4j on dbms.connector.http.listen_address, a socket address. If missing port or hostname it is acquired from dbms.default_listen_address. Supported CypherOperatorEngineOption values are: compiled, interpreted
org.neo4j.exceptions.SyntaxException: Supported CypherOperatorEngineOption values are: compiled, interpreted
at org.neo4j.cypher.CypherOptionCompanion.$anonfun$apply$1(CypherOption.scala:43)
at scala.Option.getOrElse(Option.scala:189)
at org.neo4j.cypher.CypherOptionCompanion.apply(CypherOption.scala:43)
at org.neo4j.cypher.CypherOptionCompanion.apply$(CypherOption.scala:42)
at org.neo4j.cypher.CypherOperatorEngineOption$.apply(CypherOperatorEngineOption.scala:24)
at org.neo4j.cypher.internal.CypherConfiguration$.fromConfig(CypherConfiguration.scala:66)
at org.neo4j.cypher.internal.CypherConfiguration.fromConfig(CypherConfiguration.scala)
at org.neo4j.fabric.bootstrap.FabricServicesBootstrap.bootstrapServices(
at com.neo4j.enterprise.edition.EnterpriseEditionModule.bootstrapFabricServices(
at com.neo4j.server.enterprise.EnterpriseManagementServiceFactory.createManagementService(
at com.neo4j.server.enterprise.EnterpriseBootstrapper.createNeo(
at org.neo4j.server.NeoBootstrapper.start(
at org.neo4j.server.NeoBootstrapper.start(
at com.neo4j.server.enterprise.EnterpriseEntryPoint.main(
2020-07-16 09:08:02.000+0000 INFO Neo4j Server shutdown initiated by request

Something is blocking the server to start a database web interface on port 7474.
Could it be that there is another instance already running?

Error is only with version 4.x.x databases. I can start server with databases 3.5.x versions. So there is not another instance running already.

Mmm could you post the bit of the neo4j.conf where dbms.default_listen_address is mentioned?

I am a newbie by the way I don't know if I am at the correct config file.
I opened the neo4j.conf file at Users.....Neo4jDesktop\neo4jDatabases\database-1d23d0fd-81d0-4793-a790-f31a263f31fd\installation-4.1.0\conf and this is the line with

Network connector configuration


With default configuration Neo4j only accepts local connections.

To accept non-local connections, uncomment this line:


and these are the other setting if that helps:

Bolt connector


HTTP Connector. There can be zero or one HTTP connectors.


HTTPS Connector. There can be zero or one HTTPS connectors.


Also I tried to locate same setting with installation 3.5.19 (which is running ok) but there is not a setting involving dbms.default_listen_address with that version.

In doubt, reboot
Weird log. It mixes port and cypher interpreter variant as if there would be a syntax error in a cypher query.

Jsut to clear up things a bit:
You are using the Neo4J desktop application and this happens with a newly created db?

Yes. I downloaded Neo4j desktop, installed it. Tried to start the movie database which comes wtih the installation to teach about graph databases but it gives the error I mentinoed. Also whenever I try to create a new database with version 4.x.x it gives the same error. However when I try to create a database with version 3.x.x it is working.

I have the same exact problem with Neo4j Desktop 1.3.3 & specifically DB version 4.1.0

I have the same problem. Has anyone solved it?

I've updated Neo4j, uninstalled and reinstalled it, and updated my Java per a friend's recommendation.

Is this problem local to my machine, or something universal as others have the same problems?


I found another article and followed the instructions to kill the process. My database started successfully.

Not worked for me. My problem continues with databases version 4.

Hi Okan,

I guess you are using operation system in Turkish language. I think this problem about your operating system's language. If you switch your operating system language to English. Your problem will be solved.

Have a good day.

Thanks Utku, it worked after switching to English. But what is the problem exactly in Turkish language? any ideas?

I don't know but i am researching this error's reason. Maybe it is due to the JDK. Android Studio has a same language problem too. It's a Java based Application. Already i found this answer from my Android Studio experience. If i find any new answer, i will write to this topic. If you find anything too can you write this topic?

Hi again,

I solved the problem. It is about the JDK. If you add your DB settings this line, it will be solved.

dbms.jvm.additional= -Duser.language=EN -Duser.variant=Traditional_WIN

It is changing JVM's language and we don't have to change our system language.

Have a good day.


opened an account just to thank you

It works, thank you Utku

Thank you very much.

Can you tell me please which file should I change this? I am using 1.3.11 on Windows 7. Also using JDK10