DBMS failed to start

Hello there,

I am facing a problem for a while and I still dont know whats wrong. Desktop-Version: 1.4.8
I can`t start any DBMS, no matter which version it is. Once it worked perfectly, but than I got the massage "DMBS failed to start: DBMS process terminated, see logs... "

My log.log-File:

The Ports 7474 and 7687 are not in use from other programs, so is there something that I am missing?
The config-file is also on default.

Any recommends please?!

Hi @dionisios95 ,

Sorry to hear about that, that's frustrating. There isn't a clear indication from that log file snippet about what might be wrong. The ports refusing connection could either be because the process has failed, or because something is blocking the port access.

What OS are you running on? And what user/admin permissions do you have? Can you think of anything else that might've changed on your system?

Also, could you attach your neo4j.log? In Desktop, select the DBMS, then click on the three-dots menu, then choose "Logs..." to see a window which shows all the logs. Click on the neo4j.log

-ABK

Hello Andreas,

it is working on Windows 10, admin-rights.

The neo4j.log-file:


(Neo4jCommand could not found or load)

The mentioned file neo4j-start.ps1:

Thank you for the extra detail.

The ClassNotFoundException looks like the reason for the script failing. When the script runs, it creates a "classpath" to look for Neo4j components. That is failing for some reason, either because the location is wrong or because of a permission problem.

You mention this was previously working, and that now no DBMS will launch. Does it also fail for newly created DBMSes?

-ABK

Yes it does. I will get the same error for a new created DBMS, no matter which version (4.2.x or 4.3.x)
My Neo4J_HOME (user & system)-variable is on ...\Local\Neo4j\Relate\Data\dbmss\dbms-1878d38c-984a-43e4-af4f-cc13f8b41102 , which is my main dbms, I am using.
Is this right or does this no matter?