Bloom Activation

I just download and upgraded from Neo4J desktop 3.5 to 4.0. It was my understanding that bloom was now available for free with this version, however when I go to launch it I get:

Graph-app [neo4j-bloom-id] can't be opened due to missing or expired software key

I copied the key provided at time of download but still no joy.

What am I missing?

I've had this same wrestle. He's what I did to get to the promised land.

I have a work machine, I'm admin on it and run a local copy...but it's on my work domain too. That's my SWAG as to why, no matter how I tried (outside of a complete reinstall), nada worked and I got that error too.

I had this issue on my own machine as well but no domain membership. But a simple update didn't work. Note that in the past, it had run Neo on that machine with a valid Enterprise Bloom key. So, after some frustrations, trying a download and a new Desktop key and nada, I completely cleaned Neo off that machine; saved off the databases I wanted to recreate; then installed the latest desktop download and BOOM, er...Bloom! Worked as stated.

But yes, it was not so smooth. I've updated some folks @NEO so maybe they'll help. I'm not going to do all this on my work machine, but will remain curious if a complete clean/replace would do the trick or if being a client on a domain, confuses the install process.

But it's real and thanks for pointing it out. Maybe this will help. If ya can, just "get out of the car, walk around, and get back in" :slight_smile:

HTH.

I have the same problem. I installed Neo4J Desktop 1.2.7 after deinstalling the previous version. I can't start Bloom as it raises the error 'Graph-app [neo4j-bloom-id] can't be opened due to missing or expired software key'.

I also did a complete reinstall on my machine, but this did not solve the problem. Any ideas how to solve the problem?

Edit: I found the following message in the logs, maybe this helps for detection of the problem cause:

After downloading the file https://neo.jfrog.io/neo/api/npm/npm/neo4j-bloom/-/neo4j-bloom-1.3.0.tgz, there is an error raised because a checksum is not ok... any ideas what can be the root cause for this?

[error] Shasum did not match

Under the category of "huh" and "go figure", the machine that failed to work (i.e., Bloom gave me an error and never started), two days ago decided, "ok, I'll work now". Literally nothing done except wait. And to be honest, I didn't really "wait", Bloom just popped up out of nowhere and I put 2+2 together :slight_smile:

But since then, all's "well". Very, very slow...which maybe yet another factor in the exception tree. Who knows, but thought I'd share as I did nothing but click on the same thing, the same way and this time, got the desired result.

Does that mean it's therefore "sanity". Sorry. Bad humor. HTH.