Windows Download not successful

I've tried several times to download the Desktop version of Neo4j and have had a range of errors.

If I get past that I get database, configuration, and port./ bolt errors. I'm not technical enough to know where to tinker.

Hi Jogorman,

Tinkering should not be required. The desktop client should just work. What is your OS and OS version, and Neo4j version?

I have it installed on macOS Catalina, Windows 10, Ubuntu 20.04 and 18.04. Only on Ubuntu did I do anything beyond install, and only then because I like to have Neo4j show up as an icon in my task bar... (favorites)

In my opinion, often the best way to fix an installation issue is to completely uninstall then install again. The important step is a clean full uninstall. One note, in my experience sometimes when an installation becomes corrupted, a simple uninstall reinstall may not fix it, and a deep clean might required.

If the uninstall fails to fully clean up, the next steps (possible tinkering) is often dependent on which OS (and possibly OS version) you are running and maybe the neo4j version. If you haven't yet, try an uninstall reinstall, then if that fails search for 'remove neo4j version x.x from platform x version x' here and/or in stackoverflow. Quite possibly the process has been outlined already if this happened to someone else.

Hi Joel

Thanks for your response.

I'm on Windows 7 Home Premium and trying to download Neo4j Desktop 4.2 I have uninstalled several times but there is still something not quite right. My search for 'remove neo4j version 4.2 from Windows 7' didn't turn up anything in either location.

I'm going to try it on my Windows 10 laptop.

John O'

Hello again.

So this time - after checking there were no previous installs of Neo4j - Windows 10 aborted the install after 3 seconds. Beginning to feel a little incompetent at this point, but I've got a great model and want to keep going...

Anything else I can look for?


John O';

I did have the Community Edition of Neo4j installed back in 2016, and may have tried to manually delete files a while back to install the Desktop version... will see if I can find out which files I should get rid of now.

John O'