Unable to import shapefile

Uable to import shapefile


call spatial.importShapefile("file:///shapefiles/SupportStructure.shp")


import folder:

Plugin folder:

Can anyone help on this, why I am getting this error.

Thank you

Hi @sura-nsgindia,

kindly check if you have correct version of Jar. Also try to replace this jar with new download and then restart the server.
Also try
** call spatial.procedures;** to verify procedure is available.

I tried the same as mentioned by you with complete path of the file and it worked
call spatial.importShapefile("D:\Neo4j\ApplicationData\neo4jDatabases\database-02341e23-fad3-478a-a96c-b2020042c6ae\installation-3.5.14\import\AFG_adm1.shp")

Will check and get back, thanks

Can you comment on this:


Answered to the link. Let me know if you are able to import the file as per this post?

hi @intouch_vivek , I'm also having an import shapefile problem. Here is the error :

and this is the pluggin installed in the DB (windows neo4j desktop)

any idea how I could debug this ? the jar is the latest in the plugin repo and I just tried a 3.5.2 neo4j (in case it would make a difference from 3.5.21) but it is the same error ...

I have a clean installation of Neo4j 3.5.22, and just copied these two files into plugins:


And then I ran the following commands:

CALL spatial.importShapefile('import/shp/highway');
CALL spatial.layers;
CALL spatial.withinDistance('highway', point({latitude:13,longitude:56}), 10000);

All three succeeded. I got the highway shapefile as an example from the code repository. Perhaps there is something specific about your shapefile causing the error? Do you have an error messages in the neo4j.log or the debug.log files that might relate to this?

Also, where did you get the file apoc- When I look at the APOC releases page at Releases · neo4j-contrib/neo4j-apoc-procedures · GitHub I can only download the file apoc- Yours has no -all in the name. I don't know if that matters, but was curious.