Error in Import Shape file of neo4j using cypher query

I have installed below ,

  1. Neo4j Desktop IDE with neo4j version - 3.5.17
  2. Java version 8
  3. Spatial 0.26.2-neo4j-3.5.2

Try to import shape file to neo4j through cypher query,

call spatial.importShapefile("file:///home/.local/share/neo4j-relate/dbmss/dbms-3ad2b2c1-94c6-4482-8b1f-bcfe3f413670/import/cb_2019_us_state_500k.shp")

but it produces the error : Failed to invoke procedure spatial.importShapefile : Caused by: java.lang.NoClassDefFoundError: Could not initialize class org.geotools.data.DataUtilities

how to fix this? Can anyone tell to solve this issues?

Do you have any other plugins installed in Neo4j? Sometimes there are conflicts between third party dependencies of those plugins. You could also check the neo4j.log and debug.log files for any errors when importing plugins and any further errors or stack trace when running the procedure that failed.

Thanks for reply craig,

I havent not installed any plugin, just create one database and add the "spatial plugin" to the plugin folder, but it gives the error.

I have two remaining theories. One is that perhaps this is an issue specific to desktop, which I've never tested, and the other is that it is an issue specific to your shapefile. Is there any chance you can share the shapefile with me so I can test it locally?

Thanks for your reply, Yes I have tried to import shapefile in neo4j Desktop using cypher Query, and have tried to upload my shapefile but it couldnt upload .. (here attachment support only jpeg,pdf..)