Unable to import a dump - showing error - The loaded database is not on the latest format (current:v0.A.9, latest:SF4.3.0)

Hi,

We have set up a new Neo4j database Enterprise version 4.3
I created a dump from the old enterprise version running 3.4 and tried to load it in the new version 4.3.
However, it is throwing error 'The loaded database is not on the latest format (current:v0.A.9, latest:SF4.3.0). Set dbms.allow_upgrade=true to enable migration.'

The store format in old server 3.4 is also v0.A.9. I checked by running command neo4j-admin store-info and it is showing
Store format version: v0.A.9
Store format introduced in: 3.4.0

But I am still not able to load the dump in new Enterprise v4.3.
Can someone help with a solution?

Thanks,
Bhuvana

Have you added the

dbms.allow_upgrade=true in your config file?

Yes..I did. But it is still showing this error.

This is expected. See Supported upgrade and migration paths - Upgrade and Migration Guide

we do not allow a straight upgrade from 3.4.x to 4.3.x You would first need to upgrade the 3.4. database to 3.5 and then you can upgrade to 4.3

Dear Bhuvana
Please note that even if you upgrade to latest version of product. It is my sincere urge to you that please do not remove driver version 1.0.0 from your libraries on server side.
Thaning you
Yours faithfully
Sameer G Sudhir

Thanks for the help and suggestion.

This is the post in community that helped me solve the issue.
https://community.neo4j.com/t/migrate-data-from-3-5-1-community-to-4-0-0-community/14502/9
While the process itself is quite simple and straightforward, it took a lot of time to figure out to actually implement it successfully.
I downloaded neo4j desktop and then followed the instructions from above link to upgrade the database.

Bhuvana