randomUUID not supported in neo4j version 3.5.1 community [Centos 6]


(Folterj) #1

I'm using NEO4J version 3.5.1 community.
Although randomUUID() is supported since version 3.4 (see link below) (not to be confused with similar function in APOC), and works fine in the Desktop and Docker versions, on the linux community installation I receive an error message 'Unknown function'.
In the below there is no distinction between editions. Am I missing something?

https://neo4j.com/docs/cypher-manual/current/deprecations-additions-removals-compatibility/


(Stefan Armbruster) #2

Tried on 3.5.1 community via tar.gz. return randomUUID(); worked as expected. How did you install Neo4j in your case?


(Folterj) #3

Hi Stefan,
Thanks - I installed on Centos 6 with yum, and updated with yum update. It's reporting in both bash and in the browser as version 3.5.1
Should I reinstall?


(Stefan Armbruster) #4

before doing so you could inspect the output of call dbms.functions() to check if it's listed.
Do you have any other plugins installed? if so remove them temporarily from plugins folder and see if randomUUID works.


(Folterj) #5

I currently don't have any plugins installed (the plugins folder is empty).
call dbms.functions() returns a list of only date/time related functions, randomUUID is not listed


(Stefan Armbruster) #6

same upon a reinstall? If so, I consider this a packaging bug.


(Folterj) #7

Stefan - I've uninstalled (removing /var/lib/neo4j manually as well) and reinstalled with yum, with the same result.
By the way, I've installed NEO4J on another machine with Centos 7 without problem (randomUUID working fine).

You mention this might be a package issue (on Centos 6 only?). I'm not sure I'm able to build from source, is there anything else you can think of to try?

PS: Maybe the thread subject should now be corrected


(Stefan Armbruster) #8

Good to hear that it works on Centos 7. To track down why it doesn't work on centos 6 could you please file a bug report at https://github.com/neo4j/neo4j/issues/new ?
Amended [Centos6] to the thread's subject.


(Folterj) #9

Thanks - bug reported, any further help would be appreciated.


(Folterj) #10

Just to let you know this is no longer an issue for us, as we've decided to migrate to Centos 7.