Apoc.util.md5 function not available?


(Joel Duerksen) #1

APOC loaded and accessible but the md5 function (and sha) is missing

Environment: official neo4j docker image / neo4j 3.4.7-enterprise w/apoc 3.4.0.3 plugin
I've tried version 3.5 as well, same result

CALL dbms.procedures() yield name
where name contains "apoc.util"
return name

name
"apoc.util.sleep"
"apoc.util.validate"

I'd immediately suspect an environmental issue (e.g. missing library/jar) except this is running in an official neo4j docker image.


(Andrew Bowman) #2

I believe these are functions, not procedures. Try querying again using dbms.functions().


(Joel Duerksen) #3

Yes they are! Thank you.


(Michael Hunger) #4

Always use call apoc.help("md5")

That shows you procedures AND functions.


(Joel Duerksen) #5

Thank you Michael, I'll try to remember that. (note, I don't see an algo.help). Is there a simple command to search plugins, all procedures and functions?

I know this doesn't work, but something like this

:help plugins md5


(Michael Hunger) #6

Unfortuantely extensions cannot add server commands.

If you can't call apoc.help then apoc is not installed properly.

How did you install it? And did you choose the correct version for your database version?


(Joel Duerksen) #7

Thank you, yes I'm fine with APOC, and the apoc.help function, works as you said, very nice.
Agree, and know that extensions can't (currently) add to the server command/help system, it was a thought/suggestion.

Regarding my comment about not finding algo.help, I should have just provided a separate suggestion.

It would be nice to have an official (or unofficial) guidance to add a help() function on all plugins, it is helpful.


(Michael Hunger) #8

Good idea, thanks Joel.

We have something in graph algorithms algos that's called algo.list() which we could alias to algo.help

But good idea as well for spatial, neosemantics and the graphaware plugins

/cc @jesus.barrasa @Christophe_Willemsen @craig.taverner