No option to install Apoc

Hi,
Just installed Neo4J desktop 4.1.0. When I go to install the Apoc plugin there is no option to install it.
I am not sure if it is related but our overzealous networks manager has blocked GitHub as a 'security risk'!
I downloaded the Apoc jar on another machine and copied it across. Neo4j is installed on D:\Neo4jDesktop on my machine so I created a plugins folder one level down (which I thought was the right location) and put the jar in there but still no joy!
Cheers
Mat

Look for a folder that looks something like this inside, it's probably not Neo4jDesktop where the actual database instance lives. Try a search on your machine for 'neo4j.cer' and see if that doesn't give you a different location. I have an Enterprise version installed, but the inside of your directory will look similar.

When you create a database, in the database window you will see three small circles at right top corner. Click on it and select Manage. On the next screen select the plugin tab and APOC and GDS. Click on install one after the other.

HI Thanks,

I found the right folder but placing the apoc jar in there does not seem to help

When I go to the manage option I see this:
image

Plugins option gives me this:

To: ameyasoft
Here is what my version looks like.


And after clicking on "open."

1 Like

You have to click on 'Start' button, it may take some time before the db gets started. Once the db is started, it will show as active dn at the top, where you see 'No active DBMS'

If you install it manually by copying the jar into the plugins folder it won't show it as being installed on the plugins tab, but if you open the Neo4j Browser and run CALL apoc.help() or return apoc.version() if you get back some results, it has worked!

No option to install apoc - Here's what I've got: on Desktop 1.4.9

Nothing like add plugins or anything.

Search the documentation and it's old and does have any manage button or anything to direct th user to a similar method in the new interface. It's actuallly frustrating as hell to have to manually add what used to be simple.

And also old documentation which doesn't work now is just not helpful - it's the opposite.