No documentation for APOC 3.5 anywhere to be found

I was trying to find documentation for APOC 3.5 but in the best traditions of Neo4J it looks like the older versions are simply not supported.

When I go to Neo4j APOC Procedures User Guide I see that the page has moved to APOC User Guide 4.1 - APOC Documentation but from there there's no link to 3.5.

If I Google, I get https://neo4j.com/labs/apoc/3.5 but when I open that page there is simply an error.

So does it mean you just don't support APOC 3.5 anymore and anybody who's using it should just rely on... what?