Neosemantics plugin is not detected

I'm running Neo4j Server version: 4.0.2 (community). I followed the directions on the neosemantics plugin installation.
I have

ls $NEO_HOME\plugins
apoc-               neo4j-graph-data-science-1.2.1-standalone.jar  README.txt
apoc-nlp-dependencies-  neosemantics-


more $NEO_HOME\conf/neo4j.conf | grep rdf


CALL dbms.procedures() YIELD name WHERE name STARTS WITH 'n10s' RETURN name
(no changes, no records)

APOC and GDS are working.
I saw other posts with the same problem. One solution was to make sure the plugin is in the plugins folder, which it is.
I restarted neo4j several times to no avail. What am I missing?

Thank you

Did you check the permissions on the plugin jar file?
Is ownership and r/w the same as apoc etc?

Yes, all four jars have the same permissions and ownership.

Thank you

Then I would have a look in the logs and hopefully there is a clue hidden somewhere...

Thank you, there is a whole slew of clues there :) Here is just from the top:
2020-07-10 02:11:28.528+0000 WARN [o.n.k.a.p.GlobalProcedures] Failed to load META-INF.versions.9.javax.xml.bind.ModuleUtil from plugin jar /opt/neo4j-community-4.0.2/plugins/neosemantics- javax/xml/bind/ModuleUtil (wrong name: META-INF/versions/9/javax/xml/bind/ModuleUtil)
2020-07-10 02:11:28.530+0000 WARN [o.n.k.a.p.GlobalProcedures] Failed to load module-info from plugin jar /opt/neo4j-community-4.0.2/plugins/neosemantics- module-info is not a class because access_flag ACC_MODULE is set
What follows is about two dozen of failure to load messages with the same error "com/github/jsonldjava/shaded/com/google/common/util/concurrent/internal/InternalFutureFailureAccess"
Does this provide enough information to debug the problem? or I can dump all of the error messages (which are all 'failed to load') in a file.


What version of Java are you on?
How was that installed?

java version "11.0.6" 2020-01-14 LTS
Java(TM) SE Runtime Environment 18.9 (build 11.0.6+8-LTS)
Java HotSpot(TM) 64-Bit Server VM 18.9 (build 11.0.6+8-LTS, mixed mode)

I am an absolute Java noob but it could be a version mismatch, perhaps you can open an issue on the neosemantics github project page and see if some one with more Java insight spots the issue..

We solved our problem by adding n10s.* to the whitelist in the configuration file: ,apoc. , n10s.*

1 Like

thanks for documenting this.