Neo4j 4.0 Upgrade Discussion (Desktop)

Yes please via email

Sent a few days ago; assume you received it in good order?

The 4.0.3 browser release solves this issue!
#caseclosed!

1 Like

Hello,

When i was fetching the data after connecting the MySQL database i got the below mentioned error.

***

  • Failed to invoke procedure apoc.load.jdbc: Caused by: java.sql.SQLException: Java heap space #1406*

Please help on the issue.

Thanks
Saidireddy.

Hello,

Please help above the issue.

Regards
Saidireddy.

Sai, please open a new question. Adding your own question to an existing thread is called, "hijacking," and makes it much harder to keep things organized, and for people to find the help they need.

Neo4j or your JVM need a better memory configuration. Most likely $NEO4J_HOME/conf/neo4j.conf has incorrectly sized limit, cache, or heap. Try removing any such configurations from that file, and let Neo4j use the defaults. More information is available here: Neo4j Performance Tuning

1 Like

Hi there,
after hours of working with Desktop 1.2.4, Neo4j 4.0.0 yesterday (thousands of node & rels) and shut down normally,
immagine
today I get the same dreaded password failed error as reported by paulj. database.db always unavailable; on opening, always "Password has been changed", and always "Failed - not a valid password". Have I lost the db? I've tried passord revovery:

C:\neo4j\neo4jDatabases\database-bbb4a47e-b1a4-47a8-bc7f-bcbb72b1e715\installation-4.0.0\bin>cypher-shell -d system
There is no procedure with the name `dbms.showCurrentUser` registered for this database instance. Please ensure you've spelled the procedure name correctly and that the procedure is properly deployed.

I cannot even dump the db:

C:\neo4j\neo4jDatabases\database-bbb4a47e-b1a4-47a8-bc7f-bcbb72b1e715\installation-4.0.0\import>../bin/neo4j-admin.bat dump --database=graph.db --to=./calc-12-feb-2020.10.31.neo4j
Active logical log detected, this might be a source of inconsistencies.
Please recover database before running the dump.
To perform recovery please start database and perform clean shutdown.

But I cannot start.
BTW, I had got version 4.0.0 finally working only by creating a new db and loading a 3.5.14 dump; never succeeded in simply upgrading from 3.5.14.
But now my db seems dead? what else can I do?
With so much unexpected frustration, how can I recommend this nice Neo4j to less experienced developers?

MacOS upgraded Neo4j Desktop 1.2.5. I have a graph DB at 3.5.16 and it works fine. Upgrading to any version of 4.0.x produces dialog with error when starting the DB:

Password has been changed
Local Graph password has been changed. Please enter Graph password:
Graph password

  • You can ignore this change until the next Graph start.

Entering password does not work. I tried to reset the password under Administration tab and get the same dialog. There is no password that seems to work and the DB is not available.

When I type the password in the dialog and his "Save" this is what I see in the security.log
2020-03-24 14:56:09.596+0000 INFO [neo4j]: logged in
However, the dialog does not disappear, but rather displays the following error:
Failed - not a valid password.

So, there is some conflict happening between the security log and what the dialog is doing.
Is this a specific error on MacOS desktop version?

I have seen this happening too, if I remember correctly I got around it by going to http://localhost:7474 and set the password via the web-interface.

In general it would be super helpful if you could report your issues with the desktop logs to

you find the log-files here

Thanks so much,

Michael

1 Like

Hi I'm getting a similar error - not sure of a fix. Reset the database password via the manage page. Then when starting it brings up:

Password has been changed Local Graph password has been changed. Please enter Graph password: DBMS password * You can ignore this change until the next Graph start.

Similar issue found on Stack overflow at - but not answered:

Really would like a fix for this as a demoing this to other people and Bloom isn't working with authentication set as false.