Password has been changed

I'm using Neo4j desktop on Windows 10.
Usual 'port conflict' problem occurred so I had to backup "c:\user....Neo4jDesktop" and "c:\user...\AppData\Roaming\Neo4j Desktop" and uninstall/reinstall Neo4j Desktop.
After reinstalling I copied "c:\user...\Neo4jDesktop" (also provided by Neo4j Desktop uninstaller) but not AppData\Roaming, because it looked working fine.

But then I get this error message on starting the DB restored from the backup:

"Password has been changed
Local Graph password has been changed. Please enter Graph password:
Graph password
* You can ignore this change until the next Graph start. "

passwordHasBeenChanged|620x500

I tried my old password but it says "Failed - not a valid password"

So I tried selecting 'Ignore' and browse with Neo4j browser (and with chrome: 7474)
and no queries are processed.

match (n) return n
ERROR
#### Neo.TransientError.Database.DatabaseUnavailable
Database 'graph.db' is unavailable.

In My Project tab Neo4j Desktop 1.2.4 window, the dashboard says the DB has 16 nodes (6 labels), 8 relationships (1 types),
but on Neo4j browser, Node labels: there are no labels in database, Relationship Types: NO relationships in DB, ...
(same for web browser)
Connections status seems ok:
You are connected as user neo4j
to bolt://localhost:7687
Connection credentials are stored in your web browser.

How do you people upgrade Neo4j when there's a possibility of losing all data?!

1 Like

I'm having the exact same problem after I loaded a dump of a database I got from my coworker.

Hello Wangrat and welcome to the community!

What version database is it? If it is a 3.x database, you should be able to remove the auth* files in the dbms folder and restart the database. First access to the database, you will need to change the password.

Elaine

Hello Wangrant/cnmaro/Elaine,
using desktop 1.2.4 , Neo4j 4.00 8000 nodes, 13000 relations, yesterday - after 5 hours using successfully the db, I dumped , shut down and later tried to reconnect,
NOW I GOT THE SAME PASSWORD CHANGED ERROR, AND MY DB IS EMPTY!

Desperately I created a new 4.00 db, tried to load the dump, response:

C:\neo4j\neo4jDatabases\database-eed6f3a3-a381-4b50-a410-c4e6f1c5d411\installation-4.0.1\import>../bin/neo4j-admin load --database=graph.db --from=./calc-28-feb-2020.17.37.neo4j --force
Done: 95 files, 11.41MiB processed.

result: DB EMPTY, and the same Password error,
BTW: graph.db was created, apparently with the dumped data, not shown in the browser, however.
Setting dbms.default_database=graph.db in Neo4j.conf : NO CHANGE
Not even upgrading to 4.01
What can I do?
recreate my DB would cost 10 hours, if possible; but my opinion about Neo4j is severely damaged.

Hello all,
as another try, I reopened the db, "Password has been changed" errror, all tries result "not a valid password", continue with "Ignore", db get "active", see attached:calc1
log:

2020-03-02 08:12:03.247+0000 INFO  ======== Neo4j 4.0.0 ========
2020-03-02 08:12:03.257+0000 INFO  Starting...
2020-03-02 08:12:18.020+0000 INFO  Sending metrics to CSV file at C:\neo4j\neo4jDatabases\database-6ff8110f-e065-4ab8-bf28-802e84d67dcb\installation-4.0.0\metrics
2020-03-02 08:12:18.071+0000 INFO  Bolt enabled on localhost:7687.
2020-03-02 08:12:18.077+0000 INFO  Started.
2020-03-02 08:12:18.256+0000 INFO  Server thread metrics have been registered successfully
2020-03-02 08:12:19.381+0000 INFO  Remote interface available at http://localhost:7474/

in Chrome browser: NOTHING, in browser console:

Uncaught TypeError: Cannot read property 'call' of undefined
    at a (app-ec77be66b482b9a4b34f.js:1)
    at Object.<anonymous> (app-ec77be66b482b9a4b34f.js:6)
    at a (app-ec77be66b482b9a4b34f.js:1)
    at Object.90 (neo4j-driver.chunkhash.bundle.js:1)
    at a (app-ec77be66b482b9a4b34f.js:1)
    at Object.<anonymous> (app-ec77be66b482b9a4b34f.js:98)
    at a (app-ec77be66b482b9a4b34f.js:1)
    at Object.<anonymous> (app-ec77be66b482b9a4b34f.js:6)
    at a (app-ec77be66b482b9a4b34f.js:1)
    at Object.<anonymous> (app-ec77be66b482b9a4b34f.js:331)

Neo4j browser with NO data.
:dbs says:

### Available databases

Databases available for the current user.

Either you don't have permission to list available databases or the dbms you're connected to don't support multiple databases.

If you know you have access to a database with a certain name, you can use the `:use databaseName`  command to start using it.

In dir databases I have graph.db,neo4j,system; I try :use graph.db, result:noGraphdb
:use neo4j stucks for 2min, then: "Database 'neo4j' is unavailable."
NO entry in neo4j.log. in debug.log only a lot of load errors from the included apoc4.0.0.0
in security.log:...

2020-03-02 08:37:43.899+0000 ERROR Unknown user failed to log in: org.neo4j.kernel.api.security.exception.InvalidAuthTokenException: Unsupported authentication token, missing key `principal`
2020-03-02 08:37:44.252+0000 INFO  [neo4j]: logged in
2020-03-02 08:37:44.444+0000 INFO  [neo4j]: logged in
2020-03-02 08:37:44.555+0000 ERROR Unknown user failed to log in: org.neo4j.kernel.api.security.exception.InvalidAuthTokenException: Unsupported authentication token, missing key `principal`

has the principal key to do something with multiple dbs in the 4.0.0 version? BTW same problems on another machine with version 4.0.1
Is my db definitvely gone? I become still more disillusioned!

Hi all,
another try with same dump, imported in version 4.0.0, upgraded to 4.0.1, error as above, respond with "Ignore.." , opening sees the actual number of nodes/rels, in log I see:

2020-03-02 08:57:44.297+0000 INFO  ======== Neo4j 4.0.1 ========
2020-03-02 08:57:44.302+0000 INFO  Starting...
2020-03-02 08:57:55.329+0000 INFO  Called db.clearQueryCaches(): Query cache already empty.
2020-03-02 08:58:02.126+0000 INFO  Sending metrics to CSV file at C:\neo4j\neo4jDatabases\database-64e81a90-87f2-4e84-8633-acc105bb8270\installation-4.0.1\metrics
2020-03-02 08:58:02.160+0000 INFO  Bolt enabled on localhost:7687.
2020-03-02 08:58:02.163+0000 INFO  Started.
2020-03-02 08:58:02.319+0000 INFO  Server thread metrics have been registered successfully
2020-03-02 08:58:03.429+0000 INFO  Remote interface available at http://localhost:7474/
2020-03-02 08:58:04.653+0000 WARN  Unsupported authentication token, missing key `scheme`: { user_agent='neo4j-javascript/0.0.0-dev' }
2020-03-02 08:58:04.932+0000 WARN  Unsupported authentication token, missing key `credentials`: { scheme='basic', principal='neo4j', credentials='******', user_agent='neo4j-javascript/0.0.0-dev' }
2020-03-02 08:58:22.266+0000 WARN  The client is unauthorized due to authentication failure.

in databases, always graph.db, neo4j,system;
now Chrome opens the browser, and MIRACLE:
MY NODES ARE THERE! and I can continue to work even connecting via Javascript
Password was from the previously dumped 4.0.0 version!
But the Desktop browser db is void, and :dbs responds with multi
I really don't need multi support, have only one db, should I delete the neo4j directory? I'll try.
How could I get a "principal key", to introduce a valid password? A kind of key for a payed version?
Thanks, now I'm almost happy to be able to continue with my experimental ontology browser, based on a part of Neovis. Thanks for the patience to read all my debugging tries, perhaps the Neo4j team finds them useful.

Hello,

One thing to note is that in 4.0, you cannot use "." in the name of a database. That is graph.db is not a valid name. I don't know if that is what is causing the issues, but when you load from a dump file, make sure you do not specify graph.db as the name of the database.

Elaine

Hello Elaine,
it's more complicated: I had loaded so:

../bin/neo4j-admin load --database=neo4j --from=./calc-02-mar-2020.10.30.neo4j --force

and got reapeatedly:

C:\neo4j\neo4jDatabases\database-64e81a90-87f2-4e84-8633-acc105bb8270\installation-4.0.1\import>../bin/neo4j-admin load --database=neo4j --from=./calc-02-mar-2020.10.30.neo4j --force
Done: 95 files, 11.41MiB processed.

otherwise, a back-quote is error:

../bin/neo4j-admin load --database=`neo4j` --from=./calc-02-mar-2020.10.30.neo4j --force
Invalid value for option '--database': Invalid database name '`neo4j`'. (java.lang.IllegalArgumentException: Database name '`neo4j`' is not starting with an ASCII alphabetic character.)

but - you're right - the database name must be inside backquotes (NO single or double quotes), and the resulting answer is still more confusing:
useGraphdb
in config, I had uncommented: dbms.default_database=neo4j
Hence, your comment resolves nothing, there must be some incompatibilities between Neo4j 4.0, multiple databases and the principal password. Only a Neo4j developer can help, if she/he can.

After you load the database with neo4j-admin load, you must:

:use system
:CREATE DATABASE graph.db

At that point when you type:

:SHOW DATABASES

It should show the database as online.

Can you get that far?

Hi Elaine,
NO AVAIL! I always have the Password has been changed ERROR after loading (either in graph.db or neo4j). and:unknownCreate
Same with neo4j. I cannot simply continue with my db.
After dozens of trial loads and config changes, I'll wait for a Neo4j developer answer about the "lacking principal key" which causes the initial Password error. Its perhaps the comunity version? which doesn't support multiple databases in Neo4j 4.0? It's a shame that they proposed such an immature "upgrade".

Because the database name has a period in it, you need to escape the database name since the period is not allowed in 4.0.

CREATE DATABASE graph.db

See if that works for you.

Elaine

Elaine,
NO, i cannot even connect to the db, because of the initial "Password has been changed". I still

Hello irler,

In cypher-shell or Neo4j Browser for your instance, how many databases are shown when you enter:

:USE system
SHOW DATABASES;

Do the names of the databases correspond to the folders you have in the databases and transactions folders? If not, then you should remove any folders that are not shown by SHOW DATABASES as they are not known by the system database.

Is there any chance that you could create the database without the name graph.db (no periods in the name), load it, stop it, dump it, and the try loading it again with a different name? Note that after the load, you still need to create it. For example:

:USE system
CREATE DATABASE xxx;
:USE xxx
<load the database (not sure how you are loading it, with Cypher?>

:USE system
STOP DATABASE xxx;

....

load database with neo4j-admin using a different database name yyy
CREATE DATABASE yyy;
:USE yyy

Elaine,
finally, I have my db back, i.e. solved the initial blocking:
" Local Graph password has been changed" has disapeared, I did:

  1. create new db
  2. edit neo4j.conf:
    dbms.default_database=neo4j
    dbms.allow_upgrade=true
    3.loaded the old dumped 4.0 version:
    ../bin/neo4j-admin load --database=neo4j --from=./calc-31-gen-2020.18.53.neo4j --force
    4.opened the db (neo4j)
    5.Heureka all >8.000 nodes/13.000 relationships present.
  3. disconnect/connect works for the moment

the success came after a dozen of trials with different PCs and databases:

without --database=neo4j, I always loaded a graph.db (probably because the dump had saved it as such), hence there was neo4j, graph.db, system, always got the strange "passord changed.." error, db disapeared, notwithstanding filled with files, in browser, :dbs responded with no multiple databases allowed. Probably, if loading a graph.db, there are too much dbs.
neither could I CREATE or USE one of the dbs: always "not present"

Now I can only hope, to be able continue to fill my db. Thanks for the suggestions
WJI
PS: my db contains the "ontology" of my mechanical calculating devices which I browse with the help of a hacked version of Neovis.

Excellent! Good luck!

Elaine

got the very same problem as OP, updated from db version 3.5.14 to 4.0.2. (i should have rtfm :D The following upgrade path is supported: 3.5.any → 4.0.3 )

Can somebody help me? It occures this " The password has been changed" Im with Desktop 1.2.4, the nodes can be seen, but only on the dashboard.