How to link Amazon Certificate with neo4j instance running on EC2 server?

aws
ec2
security

(Kutomer) #1

I've created a neo4j database running on an EC2 server using the aws marketplace, and an A record for that server elastic IP in route 53, and it's working:

http://[URL]:7474:
enter image description here

http*s*://[URL]:7473:
enter image description here

So I have no idea how to setup a matching certificate (I have an approved amazon certificate) found a few tutorials that explain how to do that with nginx and apache, but none for neo4j.

help will be very much appreciated.
Tomer.


(M. David Allen) #2

Just about two weeks ago we published an in-depth walk-through about how to do this. I think this is exactly what you need to do:


(M. David Allen) #3

If you already have a certificate, you can skip the LetsEncrypt steps and go straight to the bit where you configure neo4j to use that certificate.

Please remember! If you're using the cloud images you should be configuring /etc/neo4j/neo4j.template and not /etc/neo4j/neo4j.conf. More information on how the cloud images work can be found here.


(Kutomer) #4

Thanks, it worked!

One more question - how do I install a plugin on a remote server? tried it with with the desktop app but It says "This plugin is not installed on all graphs" (obviously it refers to the remote graph cause the local GraphQL plugin works)

I also tried to uninstall and reinstall but I didn't work.

edit:
Maybe it's because -


(*no graphql plugin.jar)

so I tried to:

  1. download the latest .jar from github (3.4.0.1) to /var/lib/neo4j/plugins and now it looks like:
  2. uncomment dbms.unmanaged_extension_classes=... and change to org.neo4j.graphql=/graphql not sure it makes sense though.

But still doesn't work...
Tomer.


(M. David Allen) #5

Dropping the jar into the plugins directory is the right thing to do. The config also looks probably OK to me. There are two things to check:

  • Make sure you're editing /etc/neo4j/neo4j.template for the config (and not /etc/neo4j/neo4j.conf)
  • Check your debug.log file (generally in /var/log/neo4j) and see if there are any errors related to plugins

Note that when you install a new plugin, a server restart is required (sudo systemctl restart neo4j)


(Kutomer) #6

Thanks again! it's working