Database failed to start: DB [database-02706ad0-a3b6-4e2f-a67e-457b608eb3ac] 'v3.5.14' exited with status 'KILLED'. Check the logs

Hi,

Pleace help me. When i start my graph, it appears the error in the title. What should i do, i really need that for my bachelor thesis and would be very happy if someone can write me. I have tried to restart the programm, but nothing.. I also have raed the advices in the forum and tried to follow then, but nothing

Hello @hristian.h.hristov,

Did you try to recreate the database?

Regards,
Cobra

Hi,@Cobra
I have tried to restart my computer, because one of the advices was to do that. Nothing. I am not a programmierer, therefor i do not know what means recreate a date base. I am afraid that i lost the data i have created before, 108 nodes and 120 relationships .. can you connect with me on my gmail or facebook

gmail: hristian.h.hristov@gmail.com
facebook: Hristiyan Hristov

When I said recreate the database, I mean create a new database:) Your database looks very small so it should be quick:)

Regards,
Cobra

the problem is that, it doesn't happen for the firts time. And i don't have much time for recreating everything again, it tokk me 2 weeks to do that. May I contact you out of the forum ? I would be very grateful, really :))))

First of all, you should defenitly create a cypher script to recreate your database anytime :slight_smile:

This error happened to me when :slight_smile:

  • I updated Neo4j Desktop or a Neo4j Database when it was running
  • I upgraded a Neo4j Database when it was running

Before you close Neo4j Desktop or do an update, you must close the database properly :slight_smile:

Sorry, but I don't provide help outside of this forum :confused:

Regards,
Cobra

Cabra, thank you very much for the answer.

I am a student in germany and the work with the neo4j is a part of my bachelor thesis. The problem is that I don't understand what you mean when you say create a cypher script. I didn't update or upgrade the neo4J. Yesterday when i worked with it, at the end i just closed the graph and than stopped it runninng. Afterwards i shut down my PC. Today morning i opened neo4j and when i clicked on the graph in my project, appeared this title. 108 aren't much, but every one node has 9 properties and every time they are different. So it took me 2 weeks for that, for you it may be easy, but i study economics etc. :) So how can i create a cypher script to recreate the already existing database :)

Which version of Neo4j Desktop are you using and what is the version of your database?
Where did you find the data that you put in your database?

By script I mean a file where you can write all cypher requests you used to put the data in it, like this in the future you will just have to copy pasta cypher requests in Neo4j Desktop, you can even save these requests in Neo4j Desktop :slight_smile:

Regards,
Cobra

Hi Cabra

The version of the data base is 3.5.14 and the version of the desktop is 4. I interned the database manually, that were the CVS of persons, name, age, education, university etc.

Now when I don't have an access to the graph, starting it, but I although see that there are created nodes and relationships, can i recreate my database that i entered before.

How can I create this Cypher script, that must be done before starting the work with Neo4j, at very the beginning?

Regards

На сб, 6 юни 2020 г., 15:54 Maxime via Neo4j Online Community <neo4jcommunity@discoursemail.com> написа:

Neo4j Desktop version is something like 1.2.8 not 4 :slight_smile:

Do you use Neo4j Server or a local database created in Neo4j Desktop?

How did you import your data in the database?

Regards,
Cobra

oh, you are right, the version is 1.2.4. I use local data base, i think so. I import my data manually, for example i write the code create ( p:Person{ name"Jack") etc.

I see :slight_smile:

  • First update Neo4j Desktop to the last version :slight_smile:
  • After, create a local database with the latest version of Neo4j (4.0.4) :slight_smile:
  • To finish, in a text file, write all cypher requests you are using to import your data :slight_smile: Like this if it happens again, you will just have to copy pasta everything at the same time :slight_smile:

Regards,
Cobra

1 Like

Cabra,

Could you say me how I can create a Cypher script file. I have read in the forum but didn't get it. Do you know somebody knows the Neo4j and would like to help me out of the forum, I will pay if it is necessary

На сб, 6 юни 2020 г., 16:17 Hrisi Hristov <hristian.h.hristov@gmail.com> написа:

So a Cypher script file means for example a word document where I store my code and in case an error appears I could copy paste it?

Yes, just open a txt file and put your requests in it :slight_smile: It will be the easiest way for you :slight_smile:

Regards,
Cobra

Hello Hristian,
I already had this error sometimes. and I found a workaround, similar to the advice from Cobra:

  1. exit from db (I suppose you are in Windows, in Unix it's similar set .sh instead of .bat)
  2. goto the import directory (something like:C:\neo4j\neo4jDatabases\database-56ce1c35-11f6-4006-9521-dc42a79a7cd2\installation-4.0.4\import)
  3. create a dump.bat file like this:
for /f "delims=" %%# in ('powershell get-date -format "{dd-MMM-yyyy.HH.mm}"') do @set _date=%%#
 ../bin/neo4j-admin.bat dump --database=neo4j --to=./mydb-%_date%.neo4j

(check if database name inside data/databases is neo4j, before 4.0 it was always graph.db, eventually set --datebase=graph.db)
4.open command prompt, do cd C:\neo4j\neo4jDatabases\database-56ce1c35-11f6-4006-9521-dc42a79a7cd2\installation-4.0.4\import
5. execute dump.bat, wait a while, should create a .neo4j file there
6. create a new database, fill it with one dummy node
7.in directory import create a load.bat:

../bin/neo4j-admin load --database=neo4j --from=./nameof dump. with data.neo4j --force

, eventually graph.db instead of neo4j, if refused
8. execute load.bat, should recreate your db.


this is the procedure to save my own db after the error above, I'm actually in Desktop 1.2.7 (upgrade to t.2.8 never worked) and neo4j 4.0.4
Fortunately after having opened the newly created db, all went fine,
BUT the next day I had again the same error,
first error in log: Unable to register procedure, because the name apoc.spatial.sortByDistance is already in use., I uninstalled apoc and got it again: Starting Neo4j failed: Component 'org.neo4j.server.database.LifecycleManagingDatabaseService@191ec193' was successfully initialized, but failed to start. Please see the attached cause exception "org.neo4j.graphdb.event.TransactionEventHandler
whole log file is attached
20200606-WolfgangIrler-error-log.txt (10.8 KB)

I fear I have to repeat the procedure described above, good luck for you
Hopefully, some developer reads this and find the error
WJI

1 Like

Thank you, Cabra, thank you irler, for the information. I will use it by working with the Neo4j. I have another question. After I create my graph I need to brenn it to CD so that my professors from the university could just see what I did. But when I write my code in a separate text file, ecerytime when I copy paste it in the Neo4j browser it shows me an error because the code is not aligned correctly. What advice would you give me?

@Cabra @irler.clesius With another words, how can I align/format the code from my text file in Neo4j browser

Hi,
what do you mean with "align"? please, paste the whole cypher error.
I suppose this is more a problem with quotes, hence check if " and ' quotes match always. A constructed code in a text editor may have another quote sequence than necessary for cypher.
BTW, in my last explanation, I forgot to mention to disable an important conf line:

Whether requests to Neo4j are authenticated.
To disable authentication, uncomment this line
dbms.security.auth_enabled=true

I was remembered this (necessary for upgrade from 3.5 to 4.0), when I repeated again my own recommendations, because without enabling, I got the former "password error".

Now for "brenning" a Cd for your professor. For visualizing a neo4j without server, I use a screenscanner to scan still images (cypher + nodes display) or still better, a short film using the neo4j browser. Alternatively you could put your db in a Neo4j sandbox and communicate the address.

1 Like

@irler.clesius do you know if there is an alternative way to use Neo4j. I'v heard that there is online Neo4j server, something like a cloud where I work online and there is no possibility that the data base go lost