Connect to remote graph issue

Hi, I'm trying to connect Neo4j remote Graph and I have tried almost all of the methods in community but they don't work for me. My Neo4j is the latest version.
Here are my settings of database:

Network connector configuration


With default configuration Neo4j only accepts local connections.

To accept non-local connections, uncomment this line:


You can also choose a specific network interface, and configure a non-default

port for each connector, by setting their individual listen_address.

The address at which this server can be reached by its clients. This may be the server's IP address or DNS name, or

it may be the address of a reverse proxy which sits in front of the server. This setting may be overridden for

individual connectors below.


You can also choose a specific advertised hostname or IP address, and

configure an advertised port for each connector, by setting their

individual advertised_address.

By default, encryption is turned off.

To turn on encryption, an ssl policy for the connector needs to be configured

Read more in SSL policy section in this file for how to define a SSL policy.

Bolt connector


HTTP Connector. There can be zero or one HTTP connectors.


HTTPS Connector. There can be zero or one HTTPS connectors.


Number of Neo4j worker threads.



SSL policy configuration


Each policy is configured under a separate namespace, e.g.


can be any of 'bolt', 'https', 'cluster' or 'backup'

The scope is the name of the component where the policy will be used

Each component where the use of an ssl policy is desired needs to declare at least one setting of the policy.

Allowable values are 'bolt', 'https', 'cluster' or 'backup'.

E.g if bolt and https connectors should use the same policy, the following could be declared


However, it's strongly encouraged to not use the same key pair for multiple scopes.

N.B: Note that a connector must be configured to support/require

SSL/TLS for the policy to actually be utilized.

see: dbms.connector.*.tls_level

SSL settings (dbms.ssl.policy..*)

.base_directory Base directory for SSL policies paths. All relative paths within the

SSL configuration will be resolved from the base dir.

.private_key A path to the key file relative to the '.base_directory'.

.private_key_password The password for the private key.

.public_certificate A path to the public certificate file relative to the '.base_directory'.

.trusted_dir A path to a directory containing trusted certificates.

.revoked_dir Path to the directory with Certificate Revocation Lists (CRLs).

.verify_hostname If true, the server will verify the hostname that the client uses to connect with. In order

for this to work, the server public certificate must have a valid CN and/or matching

Subject Alternative Names.

.client_auth How the client should be authorized. Possible values are: 'none', 'optional', 'require'.

.tls_versions A comma-separated list of allowed TLS versions. By default only TLSv1.2 is allowed.

.trust_all Setting this to 'true' will ignore the trust truststore, trusting all clients and servers.

Use of this mode is discouraged. It would offer encryption but no security.

.ciphers A comma-separated list of allowed ciphers. The default ciphers are the defaults of

the JVM platform.

Bolt SSL configuration


Https SSL configuration


Can anyone help with that? Thanks!


Is Neo4j Server on a Linux or Windows distribution?
I manage several Neo4j server and I use this configuration:




I hope this will help you, don't forget to restart your database after you updated the neo4j.conf file.

Received with thanks , it's on MAC.

Did it work? If yes, you can close this subject :)

The original graph is running good but I still can't remotely connect.


Have you changed the login and the password of the database?
Did you tick the encrypted connection box or not?

I have edited the setting according to your suggestion, the orginial graph works, but it still can't be connected from other computers.
Login is neo4j and I have changed the password.
Neither tick the encrypted connection or not doesn't work, I tried both~


Is the remote graph on the same computer or a distant server?

What do you mean by "the orginial graph works"?

The remote graph is on a distant server.

The original graph means the graph I wanna connect to from the distant server.


What is the distribution of remote server?

And your personnal computer on MacOS, right?

What version of Neo4j Server are you using?

Remote server is windows 10 base. And the graph I changed settings is on MacOS.
Both of these 2 computers have Neo4j 4.0.4& Neo4j Desktop 1.2.8.


The configuration I gave you is for the Neo4j Server on Windows 10, you don't need to change anything on Neo4j Desktop that is on MacOS :)

How is it going? I hope it resolves your issue:)

Thanks! Plz tell me if anywhere I misunderstood.

  • Go to the Neo4j remote server on your Windows 10 Server and use the config I gave you
  • Restart the remote server and take a screenshot where I can see the status of the service
  • After go on your MacOS computer and start Neo4j Desktop and use the login / password of the Neo4j remote server:)
  1. Windows10:

  2. MacOS:

  3. Windows 10:


No problem :) if you want to use Neo4j Desktop on Windows Server, you must use localhost and not the server IP:) You only need the server IP when you are not on the server:) If your problem is resolved, you can close this topic:)

Hey, thanks for squeezing time to help me, but I haven't solved the prob yet.
I'm using microsoft remote Desktop, Mac Neo4j desktop is on the left side and the right side is windows 10 Neo4j desktop.
For Neo4j in Mac, my setting is default.
For Neo4j in Windows 10, my setting is reset according to your configuration.
My target is running project called MKG1 on Mac as well as remotely connecting to MKG1 on Windows 10.

I tried hundreds of times but it is still not working. Could you plz have a look at it?

Thank you again!

We are gonna find what is the issue:)

To be sure, you must install Neo4j Server on your Windows server: and use the configuration I gave you.

After you can use Neo4j Desktop to access the Neo4j Server:

  • if you are on the same machine of the Neo4j server: use localhost in Neo4j Desktop
  • if you are outside the server, so on your Mac, you must specify the server adress that hosts Neo4j Server.

You cannot access a local database created with Neo4j Desktop from another computer, it must be a Neo4j Server (and not a local database created by Neo4j Desktop) if you want to access this one remotly :)

1 Like

Also please check for inbound rules for neo4j ports at server(nic) and os level(In your case win firewall)..


1 Like