Connect to remote graph from desktop

I have Neo4j Enterprise installed on GCE and also Desktop. How do I connect remotely to the GCE instance from the desktop? I try using the browser URI with bolt port but the instance is not configured and it doesn't appear that I can access the dbms configuration settings.

Hi Eric,

To connect to the Instance running on GCE from your local Neo4j Desktop, you will need to:

  • In your project, Add Graph
  • Click "Connect to Remote Graph"
  • Enter the correct URL for your GCE instance, for example:

bolt://:7687

  • Enter the proper credentials
  • Activate that New Graph

Now when you start the Neo4j Browser within Desktop, it will connect to the remote graph.

On the GCE end, you will need to make sure:

  • Your Neo4j instance is started
  • The following is set in your configuration:

dbms.connectors.default_listen_address=0.0.0.0=true

  • Your GCE firewall rules allow inbound connections to the defined BOLT port (default 7687).

I hope this helps.

Kind Regards,

Dave

Thanks for the reply David.

I confirmed that I am performing the steps you suggest:

  • I use the External IP reported in the GCE Dashboard: bolt://xx.xxx.xxx.xx:7687. The https version of this URI works in my Chrome browser
  • Credentials are correct and are the same ones used in the chrome browser connection
  • Confirmed GCE settings are correct:
    image

I still get:

image

Also, what database name does the Neo4j Desktop want? I tried the database name listed in the Neo4j browser Database Information. the Project Name, the Project ID, even the instance name, none seem to work.

Any ideas?

Thanks!
Eric

Since you have dbms.connector.bolt.tls_level=REQUIRED

Make sure that you select the box: "Use Encrypted Connection" selected when you enter your credentials.

03%20AM

The Database name you enter is up to you and just locally indicates a name within the Desktop - it does not match this anywhere.

Kind Regards,

Dave

Ooohhh... I knew it was something bonehead on my part. Works now.

Thank you sir,
Eric