Availability of GraphQL for Neo4j community edition 4.1.1


I am new to Neo4j and installed the latest community edition server 4.1.1.
I was looking to enable the graphql endpoint for this version.
However, when I go over to the graphql releases page on github, the last available version is for 3.5.15.
Will a version be released soon for 4.1.1?
Please advise.


Welcome to the community!

I've recently built a GraphQL API with the GRANDstack and the newest version of the database didn't require me to download the old GraphQL plugin. It just worked out of the box.

Hi Michael,

Thank you for your response.
So, does this mean I can no longer user call graphql.schema from neo4j browser?
Is there a graphql endpoint for the latest version?


I'm sorry I misread your original post, I don't believe you need to enable that anymore. All you should have to do is point your existing GraphQL API at your Neo4j instance and you'll be able to work with the returned data. I'm not sure if you've used the Grandstack before but if you'll check that out you'll see examples using Apollo server to access the instance.

Sorry if you've already tried that out.

1 Like

Thank you! I will try using the Apollo Server.