You have a working connection and server auth is disabled

Have installed community server and installed as service (4.0.3)

Browse to http://localhost:7474/browser on the server works

Enter username and password, fine. Change password, fine.

Try to run any code and I get told
"ERROR BoltConnectionError: No connection found, did you connect to Neo4j?"

If I try to reconnect it seems to connect me but says "You have a working connection and server auth is disabled."

What am I doing wrong here? Nothing changed from default

I'm just started to use neo4j, I have very basic question, after using software for a while and closing it, it asked me to connect to the server with connect URL bolt:// localhost: 7687 with Username and Password but I don't remember any ID and pass? could you please help me in this regard? Thanks

Say a bit more - what version of Neo4j, are you running in Neo4j Desktop. Windows? Linux? Mac?

I’m using neo4j desktop offline version 1.3.4 on Windows 10. I can’t even browse sample “movie database” by Neo4j Browser because of mentioned “server connect” error

This means you have disabled authentication. This is a warning message that browser says if authentication is disabled. Check in the config if you have

dbms.security.auth_enabled=false

If you want authentication enabled please change this to true.

1 Like

Go into the neo4j config panel and search for

dbms.security.auth_enabled

If that value is set to true change it false. The final value should be

dbms.security.auth_enabled=false

After restarting the server now connect using browser. it should log you in without credentials.

in the browser click the DB icon shown on top left side. it should expand the panel.

Look for

server user list

and click on that link. You will see list of users in the system.

Change the password of the user you want.

now revert back to

dbms.security.auth_enabled=true

After restarting the system you should be able to log in using new credentials.

Thank for you help
I could connect to the server by ID: neo4j and
pass: my database password