Websocket issue with neo 4.1 browser

Hi,

I seem to have an issue connecting the the browser of 4.1

I keep running into the Websocket error. I had some luck connecting to the default db both via browser and cypher-shell by changing the config of the connectors (just by uncommenting some lines on listen-addresses and adding the line "dbms.connectors.default_listen_address=0.0.0.0"):

dbms.connectors.default_listen_address=0.0.0.0
# You can also choose a specific network interface, and configure a non-default
# port for each connector, by setting their individual listen_address.

# The address at which this server can be reached by its clients. This may be the server's IP address or DNS name, or
# it may be the address of a reverse proxy which sits in front of the server. This setting may be overridden for
# individual connectors below.
#dbms.default_advertised_address=localhost

# You can also choose a specific advertised hostname or IP address, and
# configure an advertised port for each connector, by setting their
# individual advertised_address.

# By default, encryption is turned off.
# To turn on encryption, an ssl policy for the connector needs to be configured
# Read more in SSL policy section in this file for how to define a SSL policy.

# Bolt connector
dbms.connector.bolt.enabled=true
#dbms.connector.bolt.tls_level=DISABLED
#dbms.connector.bolt.listen_address=0.0.0.0:7687
#dbms.connector.bolt.address=0.0.0.0:7687

# HTTP Connector. There can be zero or one HTTP connectors.
dbms.connector.http.enabled=true
#dbms.connector.http.listen_address=:7474

# HTTPS Connector. There can be zero or one HTTPS connectors.
dbms.connector.https.enabled=false
#dbms.connector.https.listen_address=:7473

# Number of Neo4j worker threads.
#dbms.threads.worker_count=


I was able to ingest data in the default neo4j server. I was also able to install and run APOC and GDS and was able to use cypher shell - but when some of these queries failed because of heap size error, I went back and checked the browser and get websocket errors. I feel that the browser is not able to interact with the db at times. Kindly let me know how to troubleshoot this issue.

Thanks,
Lavanya

I've had a similar problem as you have, except that the Neo4j Browser never worked. The solution was to add this line to the config:

dbms.connector.bolt.advertised_address=52.149.129.232

I've added your IP which is visible in the image.

2 Likes

@bratanic.tomaz it worked. Thanks.