Upgrade from 2.x to 3.4 data not seen


(Airportmarc) #1

Hello,

I am upgrading following this guide, https://neo4j.com/docs/operations-manual/current/upgrade/deployment-upgrading/#upgrade-instructions-2x, and have completed all tasks.

I run the setting migrations tool, and update the allow_upgrade setting to true.

I run the neo4j-admin import tool with this command

bin/neo4j-admin import --mode=database --database=graph.db --from=${HOME}/test/db/neo4j/development/data/databases/graph.db

I do see the new folder created. I start up the server without issue, and navigate to http://localhost:7474/browser/. However, I cant see any of the nodes/relationships.

here is the neo4j.log

2019-01-28 14:50:52.234+0000 INFO  ======== Neo4j 3.4.1 ========
2019-01-28 14:50:52.268+0000 INFO  Starting...
2019-01-28 14:50:54.219+0000 INFO  Bolt enabled on localhost:7472.
2019-01-28 14:50:55.959+0000 INFO  Started.
2019-01-28 14:50:56.850+0000 INFO  Remote interface available at http://localhost:7474/
2019-01-28 15:06:06.978+0000 INFO  Neo4j Server shutdown initiated by request
2019-01-28 15:06:06.999+0000 INFO  Stopping...
2019-01-28 15:06:07.043+0000 INFO  Stopped.
2019-01-28 15:06:57.659+0000 INFO  ======== Neo4j 3.4.1 ========
2019-01-28 15:06:57.696+0000 INFO  Starting...
2019-01-28 15:06:59.462+0000 INFO  Bolt enabled on localhost:7472.
2019-01-28 15:07:01.183+0000 INFO  Started.
2019-01-28 15:07:02.579+0000 INFO  Remote interface available at http://localhost:7474/

Any thoughts or suggestions?

Neo4j 3.4.1, Mac OSx, Chrome


(Michael Hunger) #2

Are you using desktop or a plain install? Can you check the active database entry in your settings?

What does the :sysinfo tab show?
And the db-path in the Database sidebar?