Trying to open the browser of a db hosted on azure vm

Hello everyone, I wanted to host my graph db on azure, so I followed the steps (https://neo4j.com/developer/neo4j-cloud-azure-image/?_ga=2.174562272.371806894.1563778810-1110845290.1559046406) and I read all the documentation but I still can't open my browser when typing https://{ipaddress}:7473/ into my browser and Neo4j desktop gives me a "ServiceUnvailable" error when I tried to remotely connect using bolt. But when I check the db status azure's vm by typing in : systemctl status neo4j , it's telling me that the db is active.

Please have a look here first:

If these do not address your issue, please follow up with a screenshot and maybe a few more details of what you're seeing.

I saw this post and I tried to follow the steps yet did not end up solving my problem, I am still getting "access denied" when I checked the logs, I didn't get anything that helped. keep in mind that I am not that good at ubuntu.

it is saying that remote browser is ready to use but when I enter the url on chrome it's not working. (Site can't be reached / {ip address} took too long to respond ..

Need more information to help here. Access denied is a completely different error than service unavailable you reported before.

  • Are you accessing on 7474 or 7473? (HTTP or HTTPS)
  • Have you triple checked that your firewall egress rules permit this? You should investigate this first and post your firewall config, this would be a very likely source of the problem.

The logs you're showing are on the server side. A client-side screenshot might help, also try using cypher-shell locally and see what that gives you.

I dont think the issue is from my firewall, besides chrome is allowed to go through so does neo4j desktop, and I'm using 7474 (http)

this is what neo4j desktop is returning

although it's working fine on the VM:

SECOND POST
I can only enter two photos in one reply so here's the rest:

and when I check out the status it is active and running on the VM:

My issue is that I need to get it to work normally on my browser, because I have a project that is running on localhost and I need to get it up on the cloud to proceed.

Please triple check your firewall settings.

While Chrome can get through to the browser application clearly on port 7474, you also require TCP connections to port 7687 in order for browser to make a bolt connection to the database, and that seems to be the part that isn't happening.

Using cypher-shell on the VM is not a way to verify this, because that's inside of the cloud firewall. If you get the same connection errors from cypher-shell on your local machine (not the cloud VM) then the problem is almost certainly that network traffic isn't getting through on port 7687 / tcp / bolt.

Can you please walk me through the process of trying it on cypher shell ?
I checked my firewall setting and allowed TCP connections to prot 7687, and it still did not work.

image

You need to check the Azure firewall settings, and not your own laptop.

Conceptually what's going on here is you're running an instance on Azure, and I think your problem is that network traffic isn't getting into the Azure instance. This explanation makes sense because it works on the VM but not from your machine. What's the difference? The network path between the two. By default, clouds typically block access to all ports except the ones you explicitly allow, so I'm asking you to demonstrate that you've configured Azure to allow traffic in on TCP 7687 to that IP address. If you haven't, then the problem you're seeing would be expected.

To try cypher-shell locally, simply install the neo4j tooling on your local machine using Neo4j's standard install instructions.

To do the azure firewalling bits, I recommend using the Azure docs to configure network ingresses.