RPM Installation Errors on SUSE SLES 12 SP3


(Neil Sherin) #1

Hi,

I'm trying to install the community edition of neo4j on SuSE Linux Enterprise Server 12 SP3.

I've read the documentation here

Adding the repository worked fine. However when I try to install neo4j, I am getting the following error:

t-is-neil-04:/usr/local # zypper install --download-only neo4j-3.5.1
Retrieving repository 'neo4j-repository' metadata -----------------------------------------------------------------------------[\]
Download (curl) error for 'https://yum.neo4j.org/stable/repodata/repomd.xml':
Error code: Curl error 35
Error message: Unknown SSL protocol error in connection to yum.neo4j.org:443

Abort, retry, ignore? [a/r/i/...? shows all options] (a): r
Abort, retry, ignore? [a/r/i/...? shows all options] (a): r
Download (curl) error for 'https://yum.neo4j.org/stable/repodata/repomd.xml':
Error code: Curl error 35
Error message: Unknown SSL protocol error in connection to yum.neo4j.org:443

Abort, retry, ignore? [a/r/i/...? shows all options] (a): r
Abort, retry, ignore? [a/r/i/...? shows all options] (a): r
Download (curl) error for 'https://yum.neo4j.org/stable/repodata/repomd.xml':
Error code: Curl error 35
Error message: Unknown SSL protocol error in connection to yum.neo4j.org:443

CTRL+C is the only way to back out of that loop. I also get the same result with a

zypper install --download-only neo4j-3.5.2

Any help would be much appreciated.

Thanks,
Neil


(Jenny Owen) #2

I tried reproducing the error on SuSE but couldn't. I was able to download and install Neo4j by following the code in the documentation and the reproduction steps you provided.

I suspect you might be behind some kind of firewall that is restricting access, or perhaps your curl (or dependency) libraries might need updating?

Also maybe try removing our repository:
zypper removerepo neo4j-repository
then make sure there is no neo4j stuff left:
find /var/cache/zypp | grep neo4j
That should clear any saved keys, and flags to accept/reject our gpg signing key.

Are you able to curl -v https://yum.neo4j.org/stable/repodata/repomd.xml , so that zypper isn't being used? The verbose curl output should hopefully have more clues about what's going wrong.


(Neil Sherin) #3

Many thanks for that. It was down to proxy serve settings. I've set them system-wide and it seems to have fixed the problem.