Neo4r - Problem with Connection

Hello,

Iam using neo4j Desktop and have created a local database and tried to connect unsuccessfully to my graph from R witn neo4r in the following way:

con <- neo4j_api$new(
url = "http://localhost:7474",
user = "neo4j",
password = rstudioapi::askForPassword()
)

Unfortunately this doesnt work. When i execute con$ping(), i get 404 instead of 200 and the connection object "con" gives the following information: "No registered Connection (Wrong credentials or hostname)"

I already recognized that neo4r is up to now only supporting http. Therefore i uncomment the row "dbms.connectors.default_listen_address=0.0.0.0" in the configuration file to allow non-local connection.

Furthermore, when I open the connection with the internet browser with "http://localhost:7474", the displayed server status says me that iam connected with bolt://localhost:7687 although i wanted a connection via http!
Maybe there is the source of my problem.

Does anybody has an idea or hint?

I would appreciate your help a lot! Thanks in advance,

best regards
Marian

I am using neo4j desktop version 1.2.4, neo4j browser version 4.0.2 and R Version 3.6.1

Hi,

I got the exactly same situation as yours, just wondering did you solved the problem?

Yes, just use an older Version like Neo4j 3.5.14 when creating a graph and it works :slight_smile: