Connection Refused error but it use to work fine

Hi Tribe,

I have this odd issue because NeoDesktop use to be able to connect fine to the local sample db but now for some reason I am getting connection refused error messages. I installed with all the defaults so what is the issue? I read the default is username neo4j, password is also neo4j?

I can't even find where in the Desktop/Browser use set the username/password/server?

I have been also trying to get the C# GraphClient to connect but also get the same error, I have tried passing in blank username and password as well as neo4j/neo4j. I also wasn't sure what the URI should be?

I have tried:


I have tried following the steps here but it wasn't clear where I run the commands?

"bin/neo4j stop"

I get command not found in Windows command shell, same with PowerShell.

Is there a special neo command line I don't know about? :)

Any help would be really appreciated.

Many thanks,

Hi David,

Let's just stick with Neo4j Desktop and see what works and what doesn't.
Can you start the database from Desktop and then. click Open to use Neo4j Browser to access it? You can also create a new user/password and use that one in your app.
If you can access the database from the Desktop Browser, the database is fine, and you can reset the password in the Desktop UI (see image below). When the Desktop Browser connects, verify you are still using the default ports (either in settings or the Browser UI will tell you how it connected). If Desktop detects port conflict, it will assign new ports.
You should check your ability to access the database from outside of Desktop with a web browser (e.g. Chrome) and use http://localhost:7474 and enter your username and password there. Once you verify the ability to access your database with chrome, and if app is using bolt, then the url would be bolt://localhost:7687

Hi David,

Thanks for getting back to me. :slight_smile:

When I start the Desktop app, I get a message at the top saying no active DBMS. is that the problem?

How do you get the right panel to appear? As you can see on mine there is no right panel. Thanks.

Yes it needs to be running. When you click on the database name the panel should show up, click on Start to start the database.

Oh, sorry I was being a bit slow! lol ;-)

I hadn't created a local DB yet! :slight_smile:

It's odd because the demo movie db use to work but stopped working, that is what confused me? Not sure what DB that runs off? Very odd!

I now have Cypher query questions so I guess best to post elsewhere for that? :slight_smile:

The c# code now also connects fine, yay, progress at last! :)

Thanks for your help. :)

If your interested I created it here: