Neo4j's system language problem

The language of my operating system is Turkish. I get the following error, but when I change the language of my operating system, the error disappears.
2020-10-15 09:00:06.042+0000 INFO Starting...
2020-10-15 09:00:08.606+0000 INFO ======== Neo4j 4.1.3 ========
2020-10-15 09:00:10.923+0000 INFO Sending metrics to CSV file at C:\Users\Utku\AppData\Local\Neo4j\Relate\Data\dbmss\dbms-94de1970-4450-4818-ba34-d1e753f8e331\metrics
2020-10-15 09:00:10.967+0000 INFO Bolt enabled on 127.0.0.1:7687.
2020-10-15 09:00:12.233+0000 INFO Remote interface available at http://localhost:7474/
2020-10-15 09:00:12.234+0000 INFO Started.
2020-10-15 09:18:31.444+0000 INFO Note that since you did not explicitly set the port in dbms.connector.http.advertised_address Neo4j automatically set it to 7474 to match dbms.connector.http.listen_address. This behavior may change in the future and we recommend you to explicitly set it.
2020-10-15 09:18:31.445+0000 INFO Starting...
2020-10-15 09:18:32.835+0000 ERROR Failed to start Neo4j on dbms.connector.http.listen_address, a socket address. If missing port or hostname it is acquired from dbms.default_listen_address. Supported CypherOperatorEngineOption values are: compiled, interpreted
org.neo4j.exceptions.SyntaxException: Supported CypherOperatorEngineOption values are: compiled, interpreted
at org.neo4j.cypher.CypherOptionCompanion.$anonfun$apply$1(CypherOption.scala:43)
at scala.Option.getOrElse(Option.scala:189)
at org.neo4j.cypher.CypherOptionCompanion.apply(CypherOption.scala:43)
at org.neo4j.cypher.CypherOptionCompanion.apply$(CypherOption.scala:42)
at org.neo4j.cypher.CypherOperatorEngineOption$.apply(CypherOperatorEngineOption.scala:24)
at org.neo4j.cypher.internal.CypherConfiguration$.fromConfig(CypherConfiguration.scala:66)
at org.neo4j.cypher.internal.CypherConfiguration.fromConfig(CypherConfiguration.scala)
at org.neo4j.fabric.bootstrap.FabricServicesBootstrap.bootstrapServices(FabricServicesBootstrap.java:127)
at com.neo4j.enterprise.edition.EnterpriseEditionModule.bootstrapFabricServices(EnterpriseEditionModule.java:272)
at org.neo4j.graphdb.facade.DatabaseManagementServiceFactory.build(DatabaseManagementServiceFactory.java:137)
at com.neo4j.server.enterprise.EnterpriseManagementServiceFactory.createManagementService(EnterpriseManagementServiceFactory.java:38)
at com.neo4j.server.enterprise.EnterpriseBootstrapper.createNeo(EnterpriseBootstrapper.java:20)
at org.neo4j.server.NeoBootstrapper.start(NeoBootstrapper.java:117)
at org.neo4j.server.NeoBootstrapper.start(NeoBootstrapper.java:87)
at com.neo4j.server.enterprise.EnterpriseEntryPoint.main(EnterpriseEntryPoint.java:25)
I have to use the operating system in Turkish. Is there a solution to this?

Have you tried setting the listen address to an IP address? By default it listens on "localhost" and I wonder if "localhost" is getting translated to turkish which isn't working.

Yes, i tried but result same.

If you add your DB settings this line, it will be solved.

Configuration:
dbms.jvm.additional= -Duser.country=EN -Duser.language=EN -Duser.variant=Traditional_WIN

1 Like