Neo4j on EC2: "Could not connect with the "neo4j://" scheme to this Neoj server."

I'm running Neo4j Enterprise on an EC2 instance, following the instructions here: https://neo4j.com/developer/neo4j-cloud-aws-ec2-ami/

[SEE BELOW FOR UPDATE]

If you have any ideas around this, it'd be greatly appreciated, since this unfortunately happened around 3 days before we're planning to launch. :(

Hi Samuel,
Welcome to the forum.

It seems for some reason the neo4j database is not coming up. This is not related to the protocol.

Please check the debug logs to see why the database is not up.

Also, is this a cluster or a standalone instance?

Hi,

Thanks for replying -- I actually have an update to this: I believe this original issue might have been occurring because I ran out of storage on my EC2 instance (I was at ~99% usage). This would probably explain why it worked before but suddenly stopped working. So I went to EBS & increased the storage (and did the necessary steps to reflect those changes on the EC2 instance as well).

Then, I rebooted my EC2 instance, and this is where things went wrong: now I couldn't even access the Neo4j browser at all; and I'm getting the ERR_CONNECTION_REFUSED issue.

So I ssh-ed into my instance, and found that apparently neo4j was not running.

But when I tried to start neo4j, I'm getting this error:

UPDATE #2 ...

I have fixed this. I just had to create the neo4j.log file, and I was able to start neo4j successfully. Sorry for being a noob on this; but hopefully anyone else w/ the same issue can look @this thread later.

1 Like