Neo4j-OGM - Spring Data Neo4j - Spring Boot compatibility

The recommend version for using Neo4j-OGM and Spring Data Neo4j:

Neo4j-OGM 3.0.x | Spring Data Neo4j 5 ("Kay") | Spring Boot 2.0.x |
Neo4j-OGM 3.1.x | Spring Data Neo4j 5.1 ("Lovelace") | Spring 2.1.x |

All of them require Java 8.

Spring Data Kay works also with OGM 3.1.x. This is necessary because Spring Boot 2.0.x has a build-in dependency management or "Bill of Material" that defines this version. This can be overwritten while setting <neo4j-ogm.version>3.0.4</neo4j-ogm.version> in Spring Boot 2.0.x

While it might work using Lovelace with Spring Boot 2.0, we discourage this. Lovelace is based on Spring 5.1 while Spring Boot 2 is based on Spring 5, which will cause problems in most cases.

For older versions of Spring Boot (1.5.x), you have to use Spring Data Neo4j 4.2.x with Neo4j OGM 2.1.x

Neo4j-OGM 3.x is required for and tested against Neo4j 3.1, 3.2, 3.3, 3.4 and 3.5.

1 Like