Neo4j Desktop not working; Window 10

I am unable to work with Neo4j desktop, It gets stuck on choose path scree. I checked my Path Environment variable it has "%SystemRoot%\System32\wbem". Upon hitting confirm button the error shown is:
Uncaught (in promise) Error: Command failed: wmic logicaldisk get size,freespace,caption
ERROR:
Description = Invalid namespace
at ChildProcess.exithandler (child_process.js:308)
at ChildProcess.emit (events.js:203)
at maybeClose (internal/child_process.js:1021)
at Process.ChildProcess._handle.onexit (internal/child_process.js:283)

Hello @jshubhangi2697 and welcome to the Neo4j community :slight_smile:

Did you try to uninstall / install Neo4j Desktop? :slight_smile:

Regards,
Cobra

Yes, @Cobra I tried that multiple times but the same error pops.

Do you have the last version of Windows 10 and done all updates?

yes, I have the Latest version

I never seen this error but it looks like it has been solved: https://stackoverflow.com/questions/54223764/neo4j-windows-installation

As I already mentioned I have checked my path variable and it has C:\Windows\System32\wbem which is the solution given in this post, Thanks for the reply.

Oh sorry, something I do with others softwares is that:

  • I uninstall it
  • run CCleaner (clean the registry and files)
  • restart the PC
  • install the software

Can you try this? :slight_smile: