Neo4j DB 3.5 - Docker error

Hi Team,

I was able to run successful neo4j using docker. By below commands (month before)

sudo docker run -d

But now i try to start to neo4j db, getting below error

/var/lib/neo4j/bin/neo4j: line 255: /var/lib/neo4j/conf/neo4j.conf: Permission denied

Can someone please help me why this error?

when the docker container starts it thus starts Neo4j itself. And when the docker container exits, Neo4j stops. There should be no read to 'start the db' by running /var/lib/neo4j/bin/neo4j start or similar

It was running fine with above approach I have mentioned!! Past few days Iā€™m getting the permission denied error.

What you have mentioned is other way of neo4j db start. I guess not via docker.


I started seeing that same error this week. I've rolled back to earlier versions of Neo and that did not help.

Wednesday: IT system updated my Virtual Box to version 6.0.10 (from 6.0.5 I believe). I run Ubuntu Xenial inside that, and then Docker, and then Neo4j.

Thursday: First noticed this problem, could not resolve the problem in Docker (clearing out volumes and images), so rebuilt the Ubuntu system from scratch. That resolved the problem.

Friday (today): Problem is back again. My development system was shutdown overnight, as normal.

So far, I got no idea .... but for sure, something is wrong.

For what it is worth:

$ docker run -it neo4j:3.5 /bin/bash
neo4j@192efe52ccc3:~$ neo4j
/var/lib/neo4j/bin/neo4j: line 255: /var/lib/neo4j/conf/neo4j.conf: Permission denied
neo4j@192efe52ccc3:~$ ls -l /var/lib/neo4j/conf/neo4j.conf
-rwxrwxrwx 1 neo4j neo4j 16128 Sep  6 07:10 /var/lib/neo4j/conf/neo4j.conf
neo4j@192efe52ccc3:~$ ls -l /var/lib/neo4j/bin/neo4j
-rwxrwxrwx 1 neo4j neo4j 15815 Aug 22 11:27 /var/lib/neo4j/bin/neo4j
neo4j@192efe52ccc3:~$ whoami
neo4j@192efe52ccc3:~$ uname -a
Linux 192efe52ccc3 4.4.0-161-generic #189-Ubuntu SMP Tue Aug 27 08:10:16 UTC 2019 x86_64 GNU/Linux

... keep in mind that it worked yesterday, and in-between only the host computer was restarted ...

We recently had the same issues on our multiple deployments.

We don't know the exact cause, but in our deployment scripts we were automatically upgrading to the latest last supported version of the kernel (centos). Disabling this role in our deployments resolved the issue.

File permission issues with the Neo4j docker container are a recurringly reported issue. This background may help, or at least explain the situation.

Any luck on above issue? I am running as root, no luck still face same error.

not sure how to resolve it :|

Issue resolved by doing below steps:

chmod -R 777 /mnt/nvme1n1/neo4j-db/data
sudo chown systemd-timesync:systemd-journal /mnt/nvme1n1/neo4j-db/data

sudo docker run -v /var/log/neo4j-log/:/var/lib/neo4j/logs/ -d

1 Like