Could not create the Java Virtual Machine - When i run through docker

When i try to run neo4j through docker, getting below error. Some one please assit me on this..

root@ip-10-47-97-55:~# sudo docker run \

     --publish=7474:7474 \
     --publish=7473:7473 \
     --publish=7687:7687 \
     --volume=/mnt/nvme1n1/neo4j-db/logs:/logs \
     --volume=/mnt/nvme1n1/neo4j-db/data:/data \
     --volume=/mnt/nvme1n1/neo4j-db/conf:/conf \
     --volume=/mnt/nvme1n1/neo4j-db/plugins:/plugins \

Active database: graph.db
Directories in use:
home: /var/lib/neo4j
config: /var/lib/neo4j/conf
logs: /logs
plugins: /plugins
import: /var/lib/neo4j/import
data: /var/lib/neo4j/data
certificates: /var/lib/neo4j/certificates
run: /var/lib/neo4j/run
Starting Neo4j.
'nrecognized VM option 'UseG1GC
Did you mean '(+/-)UseG1GC'?
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.


I know this is an old topic but did you ever find a solution to this issue? Thanks.

Update line endings to Unix (Line Feed, or '\n') in the docker-compose and the neo4j.conf files. This issue is solved.