Neo4j Browser responding very slowly installed on Linux

Hello Team ,

I am using Neo4j installed on Linux Server RHEL 7.4 having below browser and neo4j version
Neo4j Browser version: 3.2.18
Neo4j Server version: 3.5.4
Neo4j Browser responding very slowly while trying to run or edit the query in browser.
I am using Google Chrome Browser.

Kindly suggest.

Best Regards
Akshat

My primary OS is OpenSuse 42.3, which equivalent to SLES 12. It has KDE 5.8 and Gnome 3.20. My preferred desktop is always KDE--I used Gnome in the past but found it to be inferior to KDE. When they messed with the last decent version of it, I have disliked Gnome since inception of v3. If am forced to use it--I revert back to Gnome Classic.

I previously used your exact configuration months ago in KDE with no performance issues. I am currently at Browser 3.20 and my databases at 3.5.6 & 3.5.7 with no performance issues. I have not used Gnome recently, I could check to to see if running Neo4j in the Gnome desktop makes a difference.

~Alfonso

Hello Alfonso,

Thanks a lot!!

Can you please tell me what should i do here to solve this issue?

Thanks!!

Best Regards
Akshat

Hi Akshat,

Can you try to use incognito mode and see if the problem goes away?

David

Also can you try to compare with cypher-shell ?

Anything in the JS console of Chrome?

Could you otherwise provide a GH issue, on github.com/neo4j/neo4j-browser

Hello David ,

Thanks for the work around . Unfortunately , issue remains same.

Thanks Again !

Best Regards
Akshat

Akskat,

I do not like Chrome--I use FireFox. Try loading FireFox and see if you get the same performance.

Also, is your database properly configured for its memory allocation? Meaning, it may not be the Browser but the Browser waiting for the database to report back.

Let us know what you discover...

~Alfonso