Max Queries Exceeded Error

performance
browser
cypher
knowledge-base

(Sucheta) #1

Hi,

Recently while using Neo4j browser application, i got this error -

Max queries exceeded

And it asked me run a command which i remember partially to be-

  `PROXY INIT`

(The above query is incorrect, i don't have a record of the query)

But then i couldn't run it because the Neo4j application said not connected to neo4j.

So is there a way to increase the limit of running Neo4j Queries and make it infinite ?

And does the connection stop after max limit exceeds ?


(Paul Jongsma) #2

Hi Sucheta,

Could you tell us a bit more about your setup?
Are you running Neo4J desktop with your database on the same local machine?
Or are you accessing a remote graph via the local browser?
Were you able to do any queries before this error popped up?
If not it might be that some of your settings are not ok.

Personally I use the Desktop daily, both with remote and local databases and have never seen this error.
I am sure that, with a bit more info, we can figure out what is going on...

Best,
Paul


(Sucheta) #3

Hi Paul,

My version -

Neo4j browser version -3.2.15
Neo4j Server version - 3.4.7 (enterprise)

I am using desktop setup.

I am accessing the local browser i.e. i have put bolt://localhost:11001 as my url

Yes i was able to access the the database via queries before this error.

My settings are here in the screenshot -

The error still appears on the Terminal(but i am able to run and obtain the query result).

The error in Terminal is - (Max tries exceeded)_


Joining the Community contest
(Paul Jongsma) #4

Are the port settings in Manage > Settings matching the port number you are using?
If you have a "normal browser" like chrome or firefox what happens if you go to http://localhost:11001 ?
And try http://localhost:7474 as well if the first doesn't do anything.

Which version of Desktop are you running? I noticed you seem to be on Linux, my Mac version does not seem to have the theme options I am seeing in your screendump.

Do you have a "proxy" option in settings?
Make sure its off.

Hope this helps...
Paul


(Sucheta) #5

Hi Paul,
Yes i am using Linux.

My Desktop Version is -

Neo4j browser version -3.2.15
Neo4j Server version - 3.4.7 (enterprise)

Also, when i do https://localhost:11001 or http://localhost:11001 i get -

  not a WebSocket handshake request: missing upgrade

Image of the same -

Neo4j_chrome

Is the possible reason that i got this error of Max tries exceeded because of -

Result Frames.
I have configured the Maximum number of result frames - 300


(Paul Jongsma) #6

Not sure if it related to those result frames settings; it more looks like some handshake issue between browser and server. The same error is mentioned in https://github.com/neo4j/neo4j-browser/issues/342 although that is mentioning the embedded version which you are not using. Never seen it; perhaps @michael.hunger has?


(Andrey Varenyk) #7

Hi Sucheta!
To prevent this error you might disable "Connect result nodes" in Browser Settings.56

It seems that Browser run a lot of request in order to get a relations between nodes.

You can show the connections between the vertices by returning them in the query, like this
match (a)-[r]->(b) return a, r, b;


(Sucheta) #8

Hey Paul,
I again got the Max queries exceeded error.
As said, i checked my Proxy settings and verified with yours. I believe its as you said. But the error still persists.

Please check the settings again and reply if any changes needed -