Lost database because of Neo4j update

I have spent the past couple of years building a graph database and a front end nodejs app in Neo4j 1.0.18. Recently, the Neo4j browser stopped connecting to the database even though the front end app continued to connect to Neo4j and work normally.

So I updated to Neo4j 1.2.4 hoping that this would fix the issues. But now I can't see my database when I load Neo4j and the front end app doesn't work. The front end app connects like this...

var driver = neo4j.driver('bolt://localhost', neo4j.auth.basic('neo4j', '********'));
var session = driver.session();

I believe my database data is still located at C:\Users\admin.Neo4jDesktop\neo4jDatabases

In Neo4j, I've tried clicking "Add Graph" but everything I've tried has either failed to connect or created a new database. Perhaps I have forgotten the exact "name" of the original database (if so how do I locate the name).

Can you share your Desktop Log files?


you can just grab the data/databases/graph.db and add it to a newly created graph version 3.5.12 in the same directory

I did this and it's working perfectly. This has also fixed the issue with the connection issue with the Neo4j browser. Thanks you :smile:

So the graph.db folder is the folder I need to backup. Perhaps this could be explained better in some Getting Started tutorials.