Legacy indexing - Lucene Store closes spontaneously?

apoc

(Sander Biesmans) #1

Hi guys,

I am implementing full-text search on my database via Legacy indexing.

I managed to create a Lucene index store by using apoc.index.addAllNodes, and I am also able to search through the index using apoc.index.search. I am using Neo4j 3.4.6 Enterprise edition. In the conf I added these lines:

dbms.auto_index.nodes.enabled=true,
dbms.auto_index.nodes.keys=title, alternatives.

However, a few minutes after starting the Neo4j instance I am not able to use the apoc.index.search function anymore. In the browser I receive the error function below.

First, I checked whether my database is still consistent using neo4j-admin check-consistency, and it is. Then I thought that maybe the RAM-memory was not enough to get everything working. So to be safe, I set the heapsize and pagecache size in the Conf in such a way that more than enough RAM-memory was available for other applications. Unfortunately this is also not the fix for this issue.

Does somebody has an idea what could possibly be the problem for the spontaneous closing of the Index Reader and how this closing can be prevented?

Thanks you in advance.

Kind regards,

Sander


(Michael Hunger) #2

Can you share your neo4j.log and debug.log?


(Sander Biesmans) #3

Below you can find the timeline of my executions. There is something strange happening with the time labels (logging substracts 2 hours of the actual time), but I ignore this issue.

14:00 / 16:00 Start Neo4j service
14:00:30 / 16:00:30 Call apoc.index.search gives results
14:09:09 / 16:09:09 Call apoc.index.search gives results
14:10:10 / 16:10:10 Call apoc.index.search gives results
14:13:35 / 16:13:35 Call apoc.index.search gives error
14:13:55 / 16:13:55 Stop Neo4j service

These are my logs.

debug.log

I want to upload my debug.log, but it is 4 times larger than the maximum number of symbols I can use in a message. So I share my debug.log by this link: https://text-share.com/view/90f7604f#2es5UO4OyXLN3xZ8TnXKtu4TWW6vy9QQ

Neo4j.log

2018-10-24 16:00:04 Commons Daemon procrun stdout initialized
2018-10-24 14:00:05.553+0000 WARN dbms.auto_index.nodes.enabled is deprecated.
2018-10-24 14:00:05.556+0000 WARN dbms.auto_index.nodes.keys is deprecated.
2018-10-24 14:00:05.559+0000 WARN You are using an unsupported version of the Java runtime. Please use Oracle(R) Java(TM) Runtime Environment 8, OpenJDK(TM) 8 or IBM J9.
2018-10-24 14:00:05.572+0000 INFO ======== Neo4j 3.4.6 ========
2018-10-24 14:00:05.595+0000 INFO Starting...
2018-10-24 14:00:07.121+0000 INFO Initiating metrics...
2018-10-24 14:00:19.924+0000 INFO Sending metrics to CSV file at C:\Users\Sander Biesmans\Desktop\ESCO+Opleiding+hierarchie\metrics
2018-10-24 14:00:20.233+0000 INFO Bolt enabled on 0.0.0.0:7687.
2018-10-24 14:00:22.479+0000 WARN The client is unauthorized due to authentication failure.
2018-10-24 14:00:23.112+0000 WARN Server thread metrics not available (missing neo4j.server.threads.jetty.all)
2018-10-24 14:00:23.122+0000 WARN Server thread metrics not available (missing neo4j.server.threads.jetty.idle)
2018-10-24 14:00:26.943+0000 INFO Started.
2018-10-24 14:00:27.171+0000 INFO Mounted REST API at: /db/manage
2018-10-24 14:00:27.184+0000 INFO Mounted unmanaged extension [org.neo4j.graphql] at [/graphql]
2018-10-24 14:00:27.373+0000 INFO Server thread metrics has been registered successfully
2018-10-24 14:00:27.849+0000 WARN The following warnings have been detected with resource and/or provider classes:
WARNING: A sub-resource method, public final javax.ws.rs.core.Response org.neo4j.graphql.ManagementResource.get(java.lang.String,java.lang.String), with URI template, "", is treated as a resource method
WARNING: A sub-resource method, public final javax.ws.rs.core.Response org.neo4j.graphql.ManagementResource.options(javax.ws.rs.core.HttpHeaders), with URI template, "", is treated as a resource method
WARNING: A sub-resource method, public final javax.ws.rs.core.Response org.neo4j.graphql.ManagementResource.executeOperation(java.lang.String), with URI template, "", is treated as a resource method
WARNING: A sub-resource method, public final javax.ws.rs.core.Response org.neo4j.graphql.GraphQLResource.get(java.lang.String,java.lang.String), with URI template, "", is treated as a resource method
WARNING: A sub-resource method, public final javax.ws.rs.core.Response org.neo4j.graphql.GraphQLResource.options(javax.ws.rs.core.HttpHeaders), with URI template, "", is treated as a resource method
WARNING: A sub-resource method, public final javax.ws.rs.core.Response org.neo4j.graphql.GraphQLResource.executeOperation(java.lang.String), with URI template, "", is treated as a resource method
2018-10-24 14:00:28.294+0000 INFO Remote interface available at http://localhost:7474/
2018-10-24 14:13:55.186+0000 INFO Stopping...
2018-10-24 14:14:20.758+0000 INFO Stopped.


(Stefan Armbruster) #4

Can you please try to not use the auto index config options you've mentioned. This is a very old feature. Instead shut down the database, prune the ´index` subfolder and follow the procedure sketched at https://neo4j-contrib.github.io/neo4j-apoc-procedures/#_automatic_index_tracking_for_manual_indexes to have tracking indexes.


(Sander Biesmans) #5

Thank you for pointing out the deprecated config option. That was the solution to my problem. I did the following actions to fix my issue:

  • Replacing the dbms.auto_index.nodes.enabled=true with
    apoc.autoIndex.enabled=true.
  • Commenting dbms.auto_index.nodes.keys=title,alternatives