Java put quotes in cypher query

Tried to put quotes in a query. Because I use one procedure inside another, I need to use quotes with variable fileName.

There is the error:
"Failed to invoke procedure apoc.periodic.iterate: Caused by: org.neo4j.cypher.ParameterNotFoundException: Expected parameter(s): fileName"

The query:

@Query("CALL apoc.periodic.iterate('\n" +
            "    CALL apoc.load.json(\\\"{fileName}\\\") YIELD value as v RETURN v'\n" +
            "    ,'\n" +
            "    FOREACH ( i in CASE WHEN THEN [1] ELSE [] END | MERGE (c:C{, version: {version}}))\n" +
            "    FOREACH ( i in CASE WHEN THEN [1] ELSE [] END | MERGE (c:Ca{, version: {version}}))\n" +
            "    WITH v\n" +
    void p(@Param("fileName") String fileName, @Param("version") String version);

I have tried several options:

But they don't work. How could I fix it?

This query works and parameter fileName is correct:
    @Query("CALL apoc.load.json({fileName} ) YIELD value as v \n" +
            "MERGE(c:C{})\n" +
    void p(@Param("fileName") String fileName);

Using apoc.periodic.iterate you have to externally passing in a map of params, as shown at the end of the second last line. The following example works for me:

    "CALL apoc.periodic.iterate('\n" +
    "    CALL apoc.load.csv({ url }) yield map as row return row\n" +
    "','\n" +
    "    CREATE (record:Record) SET record = row\n" +
    "', {batchSize:10000, iterateList:true, parallel:true, params:{url:{url}}});\n")
void loadCsvData(@Param("url") String url);