I renamed my user directory on Ubuntu - now Neo4j Desktop won't start

The computer I am using for work is running Ubuntu 21.04 LTS. I got things configured in a rush at work, but when I got home I realized I wanted to change /home/oldhome to /home/newhome. Now even though I have scoured the computer for a neo4j.conf, I cannot find /home/oldhome listed anywhere. When I right-click and run the AppImage, nothing happens. But doing a ps aux | grep neo4j shows it is running:

user@laptop:/$ ps aux | grep neo4j
user       6843 75.8  3.8 5104076 634168 ?      Rl   22:08   0:03 /tmp/.mount_neo4j-EMqbrj/neo4j-desktop
user       6848 37.8  0.0  11980  1940 ?        Ssl  22:08   0:01 /home/real/Apps/neo4j-desktop-1.4.7-x86_64.AppImage
user       6853  0.4  0.2 213052 45624 ?        S    22:08   0:00 /tmp/.mount_neo4j-EMqbrj/neo4j-desktop --type=zygote --no-zygote-sandbox
user       6854  0.4  0.2 213052 45456 ?        S    22:08   0:00 /tmp/.mount_neo4j-EMqbrj/neo4j-desktop --type=zygote
user       6856  0.0  0.0 213052  9616 ?        S    22:08   0:00 /tmp/.mount_neo4j-EMqbrj/neo4j-desktop --type=zygote
user       6882  6.0  0.5 436420 86212 ?        Sl   22:08   0:00 /tmp/.mount_neo4j-EMqbrj/neo4j-desktop --type=gpu-process --field-trial-handle=4010635301309828051,8718695035637972315,131072 --enable-features=WebComponentsV0Enabled --disable-features=CookiesWithoutSameSiteMustBeSecure,SameSiteByDefaultCookies,SpareRendererForSitePerProcess --gpu-preferences=OAAAAAAAAAAgAABQAAAAAAAAAAAAAAAAAABgAAAAAAAYAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAIAAAAAAAAAA== --shared-files
user       6901  2.0  0.3 270520 51880 ?        Sl   22:08   0:00 /tmp/.mount_neo4j-EMqbrj/neo4j-desktop --type=utility --utility-sub-type=network.mojom.NetworkService --field-trial-handle=4010635301309828051,8718695035637972315,131072 --enable-features=WebComponentsV0Enabled --disable-features=CookiesWithoutSameSiteMustBeSecure,SameSiteByDefaultCookies,SpareRendererForSitePerProcess --lang=en-US --service-sandbox-type=network --shared-files=v8_context_snapshot_data:100

So I have to kill the process.

Let me try running it via shell:

user@laptop:/$ cd ~/Apps
user@laptop:~/Apps$ ./neo4j-desktop-1.4.7-x86_64.AppImage 
Warning: React.createFactory() is deprecated and will be removed in a future major release. Consider using JSX or use React.createElement() directly instead.
[22:11:24.580] [info]  Starting Neo4j Desktop 1.4.7 @ Linux 5.11.0-25-generic
[22:11:24.914] [info]  Initializing persistence
[22:11:24.914] [info]  GraphQL server is running @ http://127.0.0.1:11001
[22:11:24.992] [info]  Configuring crash reporting
[22:11:24.993] [info]  Reading settings
[22:11:24.995] [info]  Reading bundled resources /tmp/.mount_neo4j-CwGKUJ/resources
[22:11:24.996] [info]  Distribution folder for java should exist
[22:11:26.834] [info]  Will copy []
[22:11:26.841] [info]  Distribution folder for neo4j should exist
[22:11:27.767] [info]  Will copy []
[22:11:27.770] [info]  Reading bundled resources /tmp/.mount_neo4j-CwGKUJ/resources
[22:11:27.775] [info]  Distribution folder for graphApps should exist
[22:11:27.804] [info]  Will copy []
[Nest] 6942   - 08/10/2021, 10:11:27 PM   [NestFactory] Starting Nest application...
[Nest] 6942   - 08/10/2021, 10:11:27 PM   [InstanceLoader] ConfigHostModule dependencies initialized +9ms
[Nest] 6942   - 08/10/2021, 10:11:27 PM   [InstanceLoader] ConfigModule dependencies initialized +0ms
[Nest] 6942   - 08/10/2021, 10:11:27 PM   [InstanceLoader] SystemModule dependencies initialized +1ms
[Nest] 6942   - 08/10/2021, 10:11:27 PM   [InstanceLoader] n dependencies initialized +0ms
[22:11:27.867] [error] App initialization error Error: EACCES: permission denied, mkdir '/home/oldhome'

I cannot figure out how to update the configuration for Neo4j Desktop to point to /home/newhome - also deleting everything I could find, even in hidden folders ~/.config/ did not help - when it starts, it is still looking for my oldhome directory.

Thanks for your help.

@nglgzz On Ubuntu, what's the best way to make this change to the base directory ?

-ABK

Even after deleting Neo4j AppImage, and doing

sudo find / -name *eo4j* -print | xargs rm -rf 

and re-downloading Neo4J Desktop - to no avail - the AppImage has captured my old install path.

I also cannot find even with sudo recursive grep on my whole machine, the original config path.

The only workaround I found was to symlink the old folder name to my current username's home directory.