I can't launch Neo4j through the browser


(Sajan Sadhwani) #1

Hi All,

Apologies if this isn't the correct forum but I've been having a lot of trouble with getting Neo4j to launch. I went to http(s)://localhost:7474, http(s)://localhost:7473, http(s)://localhost:7687, and I get the same error. "This site can't be reached. localhost refused to connect. Search Google for localhost 7474. ERR_CONNECTION_REFUSED." I do not get a login screen at all.

I've tried the following and none of them worked.

  • I've right clicked and ran Neo4j as an administrator
  • I've turned off my firewall
  • I finally found the conf file and I've allowed external connections

I've checked online and in all the tutorials it just seems to work.

Is there a true beginner tutorial. I have a Windows 10 machine and I installed Neo4J desktop. At this time, I'm honestly just considering giving up on trying to get this to run.

Any help would be appreciated.

Thanks.


(12kunal34) #2

Hi Sajan ,

First you have to start the server then only you can access that URL.
First download neo4j server from the below URL according to your system Config.
https://neo4j.com/download-center/#releases

and then unzip the folder , inside the bin folder you must have a neo4j application . double click on that and start the server .


(Sajan Sadhwani) #3

Hi 12kunal34, thank you for the help.
I installed the Neo4j community server. I went to the directory but I do not see a Neo4j application.

I extracted the zip file to my downloads directory, and I have the following directories:
bin
conf
data
import
lib
logs plugins
run

There are some files but they are text files. I went to the readme file and it told me to go to \bin and run the Neo4j console from there. There were some batch files and clicking on them did nothing.

What am I missing?

Thank you.


(12kunal34) #4

Hi Sajan,
inside bin folder you must have neo4j community edition app.
if you are not able to find it then please search in your system . it should be there


(Sajan Sadhwani) #5

Hi 12Kuna34,

Inside my bin folder I have 2 folders and 6 files. The first directory is
Neo4j-Management" and has 24 files ending in .ps1. The second directory is called tools and has 4 files, 2 jar files and 2 exe files, "Prunsr-amd64.exe" and "prunsrv-i386.exe", neither of which do anything.

Of the 6 files, 5 are batch files, one is a file called "Neo4j-Management.psd1".

Just to be clear, I'm doing this on a Windows 10 machine.