How to share Neo4j database

Hey all,

I have been following the following guide to try to download my neo4j database to send to other employees in my company: Back up an offline database - Operations Manual

I have tried the following and a few other iterations, but nothing seems to work, so I'm thinking I just don't know how to do it.

Thanks in advance.

@jhayes8552

Can you try check by issuing the below command to have offline backup ?

neo4j-admin dump --database=neo4j --to=/dumps/neo4j/LabData.dump

Thanks

@jhayes8552
see Back up an offline database - Operations Manual

and to which it should be

neo4j-admin dump --database=<databaseName> --to=<path or resultant dump file>

Same sort of error message:

Ok is my database name my "project" or is it the name below that, see here?

image

Also: if it is offline, as it states in the guide you linked, where would I type in these codes? Sorry about the dumb questions.

@jhayes8552

where would I type in these codes?

what codes?

the value for --database= is the name of the database and not the project. If you are connected to Neo4j browser and if you run show databases; this will list the databases within the project

Gotcha.

I have these databases:

I would like to download the neo4j (which is where I've done my work, since system is a metadata file) into a dump file.

I then typed this code:
neo4j-admin dump --database=neo4j --to=/dumps/neo4j/Lab.dump

and got this as a result:

Is it the "--to=/dumps/neo4j/LAB_DBS.dump" part of my code? This seems to be the same problem I have been having throughout.

Try this: 
bin/neo4j-admin dump --database=neo4j --to=data/dumps/neo4j.dump

The same error message comes up as all the others;

Is there something that I should put before this? Or am I missing something else?

@jhayes8552

the neo4j-admin command is to be run at the command line of the OS (i.e. linux or windows) and not a command you can run from the Neo4j Browser. From the screenshot it appears you are running this from the Neo4j Browser.

1 Like

Yes I'm sorry. I'm pretty new to the Neo4j system (and why I put the question in the Newbie Questions subcategory)

Where would I go to type the query in?

Sorry again about all the questions!

@jhayes8552 open the command prompt from your Windows machine then navigate to the directory /bin folder under neo4j installer, from there you can try execute the command, as suggested by @dana.canzano. Hope this helps you to take offline backup !!!

1 Like

I've never been able to get this command to work. Windows doesn't recognize the command so I'm wondering if there were some environment variables not set during installation.

@mbandor

I have my install at

c:\Neo Kits\4.3.2\neo4j-enterprise=4.3.2\

if I cd to said dir and then to subdirectory bin and then run

.\neo4j-admin.bat dump --database=neo4j --to=neo4j.dump

then a file named neo4j.dump is created at

c:\Neo Kits\4.3.2\neo4j-enterprise=4.3.2\

I just checked my installation and I don't have a bin directory. I'm running the Community edition of the Neo4j Desktop with a local database.

Okay, I found the bin directory, just not in the place I expected it to be. I didn't realize the command was a batch file. I was looking for an executable.