Exact config file to install neo4j on Ubuntu 18.02 server

Hello guys!
I have been trying to install neo4j in ubuntu for the past one week but i couldn't achieve it. I have tried all the methods in the documentation, had seen solutions here in the community and stack overflow but of no use. I'm really tired. So i have reset the server and freshly installed the neo4j. Now's its opening in the browser using <my_ip>:7474. But when i go to <my_ip>:7687 it shows not a websocket handshake request.

By default in my browser, username is neo4j and password is neo4j.

Someone please send me the whole config file with exact details of where to change and also what commands to use in ubuntu. Also if i run a simple command in the browser like Create(n), the wheel keeps on rotating for a long time and gives me **WebSocket Connection Failure error.**

So please help. I'm out of all the methods and tired of this. Thank You!
Peace! :slight_smile:

Because you can connect to port 7474 it seems the server is running. Allthough within the browser at port 7474 the browser also connects to port 7687 (the Bolt protocol). I dont know the exact setup of your Ubuntu installation and how you connect.

Can you login to the Ubuntu and run the browser within Ubuntu and go to http://localhost:7474 and then login (maybe you will be asked to change your current Neo4j password) and then run the query at localhost:7474?

I went to the browser. It showed be localhost:7474. But when i click connect, it's not happening. So i changed it to <my_ip>:7474 in the browser. It got logged in but whenever i try to run a query, the wheel keeps on rotating and then gives me websocket error.
Peace! :slight_smile:

The deafult configuration for Neo4j is to listen on "localhost".
Maybe you changed something in the configuration file.

Can you login to the Ubuntu server and please check if Neo4j is listing on the ports 7474 7687 and if so on which IP address?
To check you can you something like
$sudo ss -ntulp

Yours Kindly

Hello! Sorry for late reply. Actually, previously my dbms.advertised_address = localhost
but now i changed it to <my_ip> and it's working. thanks.
Peace! :slight_smile: