Installing Neo4j on a Server

Having used neo4j for a while on my windows laptop, I now need to move to a location where my service is always up.

I have a linux server, connected and ready, and have done an rpm install of neo4j

  • Install on Oracle Linux (Redhat basically!)
  • neo4j version = neo4j 3.5.12
  • Ports are open and the firewalld clear.
  • I have a public IP address for the server (and a domain name)

What I don't know is how I can use neo4j and how I should integrate with nginx.

Ideally I just want to login as I do when its installed locally eg http://<server_address>:7474/browser or better still http://<server_address>/neo4j. Then I get the usual cypher screen and can run my cypher scripts.

I have read lots, but can only find install instructions that assume you are running from localhost, but I just want the neo4j system available from a web browser. Some

I also have nginx available and a certificate ready. I have tried several of the blog recommendations, which either results in an error when running nginx or a bad gateway, for example https://blog.armbruster-it.de/2018/05/using-nginx-to-proxy-a-neo4j-instance/

(btw please don't suggest other install places/ methods - like docker, aws, azure. I know other methods are available, but I have the use of a free Linux server so want to try to get that running first)

many Thanks

Adrian

Can you connect directly to http://<ip_address>:7474/browser?

You have to uncomment the following in neo4j.conf:
#dbms.connectors.default_listen_address=0.0.0.0

What error are you getting with nginx?

I just get a can't connect message, even after I edited the default listen address command,

What url is supposed to resolve is it :7474/browser ?

The nginx error is 502 bad gateway. I tried a few different settings, and then nginx wouldn't start, with a 0.0.0.0:7678 permission denied error.

I got there in the end!

First I needed to update Linux SE

semanage port -a -t http_port_t -p tcp 7474
semanage port -a -t http_port_t -p tcp 7687

Then I needed to update my cloud firewall from Source port 7474 to source All

And then I can connect directly

My next test is to get nginx in play.

Would you have any idea of the analogous steps in Ubuntu? I'm running into the exact same issue you're having and can't figure it out