Error when trying to invoke cypher procedure `apoc.spatial.geocodeOnce`

Tried to execute the following cypher query:

CALL apoc.spatial.geocodeOnce('21 rue Paul Bellamy 44000 NANTES FRANCE');

Got the following error:

Failed to invoke procedure apoc.spatial.geocodeOnce: Caused by: java.lang.RuntimeException: Can't read url or key https://nominatim.openstreetmap.org/search.php?format=json&q=21+rue+Paul+Bellamy+44000+NANTES+FRANCE as json: connect timed out

Can someone please help me out? Do I have to add any additional library for this query apart from APOC (which I have already installed)?
Eagerly waiting for a response at the earliest.

Thanks.

@sridhar.s2409

The apoc.spacial.geocodeOnce should work without additional libraries.
However, the problem seems due to the openstreetmap url, but I just tried and it works.
Maybe was a temporary problem of https://nominatim.openstreetmap.org API?
I'm quite sure that trying again now should work.
Otherwise, can you provide your Apoc version?

The API works fine but when I query through Neo4j, I get this error.

APOC Version - 4.3.0-rc01

@sridhar.s2409

I just tried with the same version, and it works.
I would suggest you to update to the latest 4.3.x apoc version, because this version is very old and unstable, but I'm not sure it could be helpful.
In case it doesn't work, can you provide your neo4j.conf and apoc.conf? Or the docker configuration, if you are using it?