ElasticSearch integration with Neo4j

I want to integrate ElasticSearch with Neo4j and I am following the steps in this repository: https://github.com/graphaware/neo4j-to-elasticsearch. The point is that when I try to run Neo4j it is saying that the connection is refused. I have the port 9200 free (so nothing is running on that port). My mapping.json looks like this:

{
"defaults": {
"key_property": "uuid",
"nodes_index": "node-index",
"relationships_index": "relationship-index",
"include_remaining_properties": true,
"blacklisted_node_properties": ["password"],
"blacklisted_relationship_properties": ["uuid"],
"exclude_empty_properties": false},

"node_mappings": [
{
"condition": "hasLabel('Provider')",
"type": "provider",
"properties": {
"name": "getProperty('provider_name')",
"labels": "getLabels()"
}
},

{
"condition": "getLabels().length == 0",
"type": "nodes-without-labels"
}],
"relationship_mappings": [{
"condition": "isType('OFFERS_PRODUCT')",
"type": "is"
}]}
-------------------------------------------------While my configuration of Es in neo4j.conf is -----------
dbms.unmanaged_extension_classes=com.graphaware.server=/graphaware

com.graphaware.runtime.enabled=true

#UIDM becomes the module ID:
com.graphaware.module.UIDM.1=com.graphaware.module.uuid.UuidBootstrapper

#optional, default is "uuid". (only if using the UUID module)
com.graphaware.module.UIDM.uuidProperty=uuid

#optional, default is all nodes:
#com.graphaware.module.UIDM.node=hasLabel('Label1') || hasLabel('Label2')

#optional, default is uuidIndex
#com.graphaware.module.UIDM.uuidIndex=uuidIndex

#prevent the whole db to be assigned a new uuid if the uuid module is settle up together with neo4j2es
com.graphaware.module.UIDM.initializeUntil=0

#ES becomes the module ID:
com.graphaware.module.ES.2=com.graphaware.module.es.ElasticSearchModuleBootstrapper

#URI of Elasticsearch
com.graphaware.module.ES.uri=15.xxx.xxx.xx

#Port of Elasticsearch
com.graphaware.module.ES.port=9200

#optional, protocol of Elasticsearch connection, defaults to http
com.graphaware.module.ES.protocol=http

#optional, Elasticsearch index name, default is neo4j-index
com.graphaware.module.ES.index=neo4j-index

#optional, node property key of a propery that is used as unique identifier of the node. Must be the same as com.graphaware.module.UIDM.uuidProperty (only if using UUID module), defaults to uuid
#use "ID()" to use native Neo4j IDs as Elasticsearch IDs (not recommended)
com.graphaware.module.ES.keyProperty=uuid

#optional, whether to retry if a replication fails, defaults to false
com.graphaware.module.ES.retryOnError=false

#optional, size of the in-memory queue that queues up operations to be synchronised to Elasticsearch, defaults to 10000
com.graphaware.module.ES.queueSize=10000

#optional, size of the batch size to use during re-initialization, defaults to 1000
com.graphaware.module.ES.reindexBatchSize=2000

Plugins in the plugin folder are:
1-graphaware-uuid-3.3.5.52.17.jar
2-graphaware-neo4j-to-elasticsearch-3.3.5.52.8.jar
3-graphaware-server-community-all-3.3.5.52.jar

Is there anything that I have to do differently in order to work with ES in neo4j, because when I do: CALL ga.es.initialized() YIELD status RETURN status, it gives me the TRUE result?????