Difficulties upgrading and migrating from Community 3.4.9 to Enterprise 4.1.1

I've just been granted a free startup licence (w00t!) and am attempting to migrate from the Community version (3.4.9) that I have deployed on a Google Cloud VM to Enterprise version 4.1.1.

The path I've chosen is Community 3.4.9 -> Enterprise 3.5.14 -> Enterprise 4.1.1

Unfortunately I've run into an issue as soon as I've upgraded my test server to E-3.5.14 where the Neo4j server keeps cycling through the startup/shutdown procedure.

I've been looking through the logs to identify the issue(s) and have found the following that stand out:

[o.n.i.p.PageCache] The dbms.memory.pagecache.size setting has not been configured. It is recommended that this setting is always explicitly configured, to ensure the system has a balanced configuration. Until then, a computed heuristic value of 1451843584 bytes will be used instead. Run neo4j-admin memrec for memory configuration suggestions.

[o.n.k.a.DatabaseAvailabilityGuard] Database graph.db is unavailable.

[o.n.i.d.DiagnosticsManager] unsupported.dbms.directories.neo4j_home=/var/lib/neo4j

[o.n.i.d.DiagnosticsManager] unsupported.dbms.edition=enterprise

[o.n.i.d.DiagnosticsManager] unsupported.dbms.udc.source = gcloud-SINGLE

I started with the first error to see why graph.db was unavailable and found that graph.db had been moved during the upgrade from the data folder to a new databases folder within the original 'data' folder. So tried to update my neo4j.conf file to reflect the new path. However, whenever I start up the Neo4j server again the neo4j.conf file resets to default values.

I'm starting to think it might be easier for me to build a new clean version of Neo4j Enterprise 4.1.1 in Google Cloud and reload my data (the database is only small). Unfortunately I can't work out from the documentation how to do that and all the versions available in Google Cloud's Marketplace are for clusters, not single VMs.

Can anyone point me in the right direction?

Thanks

I've just realised why my neo4j.conf file keeps being overwritten - I should be amending the neo4j.template as its deployed on a cloud VM. As per documentation here