Desktop v1.4.3 for Mac - can't load older v3.3x DBMS

Hi everybody - I was exploring Neo4j Desktop about 3 years ago and built several databases which I've now somehow lost the ability to see. I'm trying to pick this project back up and start playing with it again and I'm finding my skills are very rusty. Everything used to work quite nicely. I'd just pick what I wanted to work on and it would start right up. Now I can't even see any of my old stuff.

In Finder I can see my old \neo4jDatabases\database-xxxx folders, but only the default movie sample project is in the projects folder.

I tried creating a new project hoping to load my old DBMS that way but it only seems to let me create a new one, not load existing. In the DB version dropdown I noticed that the oldest version DB I can create (v3.5.15) is still newer than any of mine (mostly v3.3x or v3.4.0).

Is this a backwards compatibility issue where my stuff is just too old? If so, is there a way to migrate and save my stuff? I tried searching the community and looking through release docs but clearly I'm missing something, in addition to being a novice noob.

Any help would be seriously appreciated. Thanks! -Mason

Mac OS: 10.13.6 (High Sierra)
Neo4J Desktop: 1.4.3