Desktop not launching at all (windows)

after machine blue screen crash, neo4j desktop would not launch

it does not appear in task manager applications list, just 3 processes that remain like this

the memory used changes over time, but that's it

tried reboot machine, uninstalled and reinstalled desktop, still the same

any idea highly appreciated since I'm only a couple of days away from deadline to deliver DB before en of mission...

read different posts on the subjects but could not find anything that would solve this

UPDATE: ended up uninstalling with "delete neo4j file option" desktop reinstallation now launches, struggling with restauring DB ...

For restoring the db's if you still have the old db's around you can just copy them into place of a new one (both data/databases and data/transactions)

:exclamation:
if you run into issues with Desktop 1.4.7 on Windows could you try this and report back?

try asking them to delete the C:\Users[USERNAME]\AppData\Local\Neo4j\Relate\Cache\plugin-sources\default-sources.json file and see if that helps? We think that the reason for desktop not starting for some users might be that the cached plugin sources has become corrupt

I have tried going to the path you shared and there was no plugin-sources folder but instead this path:

C:\Users[Username]\AppData\Local\Neo4j\Relate\Cache\plugin

Only having the neo4j-jwt-addon-1.2.0.jar

I've attempted deleting this entire Neo4j folder from the AppData but no change. I've uninstalled and re-installed Desktop version multiple times and it still won't start up.

Can you share the desktop logs? best as an github issue?

Also 1.4.8 came out today which fixes several startup issues on Windows in case you want to give it a try.

Hi. Did you manage to fix this problem?

I downloaded neo4j desktop today and after initially opening it crashed and then would not reopen. I've uninstalled and reinstalled it a number of times but I have the same problem as you. It won't launch and it says there are 3 underlying processes running.

I tried deleting the json file as well but it didn't help with the application launching. Any help would be appreciated!