DeepLink in Neo4J Bloom

I am new to the Neo4J development. I m trying to use the deep link for bloom but it is giving me Page not Found error.
If I explicitly open the bloom from desktop , it works.
I have the desktop Version of Neo4J in my local system and created the local data.
I am referring the below link for deep link.

Is there any configuration i am missing.*MTYyNTExMzU2Ni4zLjEuMTYyNTExMzY1NC4w&_ga=2.23373369.2082254307.1625032992-1383686343.1624366172#_deep_links_into_bloom

I think for deep links you need the bloom plugin with a license.

Or running bloom on neo4j aura perhaps.

Hi @deepika,

deep-links should work for all types of Bloom deployments. Could I ask you a few questions regarding your setup?

  • Which version of Bloom are you using?
  • Are you using the deep-link with a server hosted deployment of Bloom or the Bloom Desktop app?
  • Could you share an example of the deep-link you created?

Thanks. I am using 1.7 version of Bloom.I am trying bloom on desktop app.

I am using below link to connect.

I am able to open the browser. "http://localhost:7474/browser". but bloom deep link is giving 404 error

Thanks Michael. is it possible to imbed bloom with Aura. i can use aura but not sure if it support bloom.

Yes Bloom is available on all Aura tiers.

Hi @deepika,

thanks for your reply. Bloom isn't hosted on localhost by a Neo4j database like Neo4j Browser is, unless the database has the Bloom Server Plugin installed.

But you can use deep-links with the Bloom graph app in Neo4j Desktop as well, like so: neo4j://graphapps/neo4j-bloom/[?<parameter>][&<parameter>].... This will open the Bloom app in Neo4j Desktop with the settings in the deep link. You can find more information on using deep-links with the Neo4j Desktop app here.

I hope this helps! Please let me know if you have any other questions or comments.

Hi Clemens,

Thanks you for the response. i am able to open the bloom graph app from desktop without any issue.

Issue occues with the deep link, Initially it was giving 404 error, later after server plugin installation it worked and asked for credentials. After providing credentials it told, you do not have permission. I have given all the permissions in the setting file, I was wondering if i needed the activation key as this is the only piece missing.

Additionally I tried to use the neo4j Graph app url. it did not give me connectivity issue but the link just keeps scrolling if the neo04j desktop is open. After closing it from task manager , graoh link proceeds. I read some where that this was the known bug and fixed in 1.6 but I am using 1.7.

Kind Regards

@ [clemens.anzmann] I have installed the nep4j bloom server plugin and then i was able to use the localhost:7474 URL. I have given username and password and it is throwing me below error.
The Neo4j Bloom Server license couldn't be verified. Please contact your system administrator.

Do i need the license key for the same.

Please note I am using the sandbox version so i have unrestricted the bloom.* procedure to get past the permission error.

Hi @deepika,

The error you are seeing appears when there is a problem with the Bloom Server License file, the location of which can be specific as a relative or absolute path in the database settings:


It sounds like you have specified a path in your settings and Bloom was able to find a file on that path but has trouble reading the file. We've encountered issues with file encodings and BOM characters in license files in the past:

Could you check that your Bloom server license file is stored in UTF-8 encoding and does not contain a BOM character?