Database is unreachable with spezified configuration

Hi,
After realizing that my Raspberry Pi 3 isn't powerful enough to run neo4j, I decided to install it on my server.
I get the Unable to establish remote connection:Database is unreachable with specified configuration.

Edit: the necessary ports are open! (7474 and 7687)


Can anyone help getting this to work?
neo4j is running and the credentials are correct!

Change the lines to:

dbms.connector.http.listen_address=0.0.0.0:7474
dbms.connector.bolt.listen_address=0.0.0.0:7687

To enable listening to all IPv4 addresses on the ports.
Or replace 0.0.0.0 with a single public IP address of your server

Note: this might open up the database too much to be secure, anyone who knows the username/password combo can access the server. Please consider using a firewall to restrict access to these ports from known addresses only.

did so.
to no avail!

I now await the deactivated fw to check whether it works without any :-D
Then I'll slowly lock it down again - if it works ...

and here's the update:

Ah yes; first step is to disable any firewall in place :slight_smile:

The connection to the server is make in two steps, first is to connect to the web-interface at :7474

That should show you the login screen of the server prompting you to login (or set a password if it is a new setup)

Once thats done the webclient connects to the bolt port, I have bee in the situation that :7474 worked but that the webclient could not connect to the bolt port because it tried connecting to localhost.

If I remember correctly that was fixed afer changing the

dbms.connectors.default_advertised_address=localhost

setting where I replaced localhost with either the name or IP of the server.

after trying it all and realising that I was not getting any work done, I skipped for now ...
I'll come back later ... I now work locally, until I get the core ideas ...

I have to say: documentation-wise neo4j is not the best option!

Some parts of Neo4J are more mystical than others ;-)

Getting connected to a remote server correctly can be daunting at first yes, but once you have it running correctly it is fine.

And getting to use Cypher instead of SQL is a big reward :slight_smile:

the server-side really bugs me ... I mean, I couldn't get it to run behind nginx or apache!
I need to figure out how to get some xml-files in there correctly and the syntax etc. :-D

At the moment it is quite complicated

to further complicate it: I come from the humanities and aim for using neo4j in some projects...

Perhaps https://neo4j.com/aura/ is something which helps?
It is basically your own private Neo4J in the cloud, admin is automated.

On the other hand I can see that running your own server has benefits also.
If you would like I could have a look at the server setup?
Mail me details on paulj@webtic.nl to work out the details.