Database failed to create: Error: EISDIR: illegal operation on a directory

neo4j-desktop

(Michael Black) #1

I'm trying to create a new local graph and I'm getting the following error:

Database failed to create: Error: EISDIR: illegal operation on a directory, open 'C:\Users\mblack\.Neo4jDesktop\neo4jDatabases\database-2c261a08-97b8-4798-a04d-7a7b5c028c84\installation-3.5.3\data'

I'm trying to install the latest version 3.5.3 which I have never done before, but I have found that I can create a v3.5.1 graph because I have created that before. So I've done something recently in my environment that is preventing the new version from getting downloaded and and installing.

I've tried uninstalling Neo4j Desktop, keeping files, reinstalling desktop but the problem persists. I'm installing the desktop for my user only and not the whole machine.


(Michael Black) #2

I just tried this on a different computer and had the same bug, so I'm inclined to think it's truly a bug with Neo4j Desktop and not the computer environment.


(Matthiaspchan) #3

I also had this same problem with 3.5.3, but was able to use a 3.5.2 instance.

Tried uninstalling and redownloading as well. Using Desktop 1.1.13


(Michael Black) #4

On GitHub where I also reported this issue, the desktop team came back saying that in about a week there'll be a update and fix


(Rmasrani) #5

Hi Mike - is there a solution? I am experiencing the same problem - and have also reinstalled everything.


(Michael Black) #6

Since the new version of the Neo4j Desktop application, I haven't had the issue. I have version 1.1.17 of the desktop.